• Resolved MarkOlbert

    (@markolbert)


    I’ve configured MailPoet to use its own sending service (I currently have only a couple of hundred subscribers). I’m using the “visitors to website” option for sending emails.

    I’ve created a subscription page and used it to add a dummy subscriber. Everything appeared to work okay and the standard “check your inbox” message was displayed.

    But not confirmation email was ever received at the address. And I know the address works because I sent an email outside of MailPoet to it just now.

    I also created and sent a dummy newsletter to myself from within MailPoet. That was marked as being successfully sent…but again no email ever arrived.

    The system status page does not indicate any problems. Task scheduler, key activation and MailPoet Sending Service all show as fine. The cron shows as having run several times since I tried to send all these emails.

    Scheduled tasks and running tasks don’t show anything. Completed task shows that test message I sent as having been successfully processed. But again, nothing ever arrived.

    I guess I won’t have to worry about overloading anyone’s email inbox using MailPoet… 🙂

    Thoughts on what might be wrong? Or on how I can get some more diagnostic information?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author MailPoet

    (@wysija)

    Hi @markolbert,

    Can you please use this tool to check your SPF and DKIM keys for the domain you’re using for the FROM email address?

    Since you’re experiencing deliverability issues when sending with us, you may still have an SPF record set up for a previous sending service, like Google Suite (Google Apps).

    In this case, you need to include our sending service domain (include:spf.sendingservice.net) to the list of servers authorized to send on your domain’s behalf or simply remove the previous SPF record.

    Let us know!

    Hi,
    The result is :

    SPF check
    1 SPF record found for the domain lionsdistrict103se.fr :
    “v=spf1 include:mx.ovh.com ~all”

    DKIM check
    No DNS record found for default._domainkey.lionsdistrict103se.fr

    what do I have to do, please ?

    Thanks

    LOL! The day I ran into the problem I had been working very late the night before and forgot to check my junk mail folder. The test messages were there. I sent a new test message and confirmed that it was delivered.

    However, I ran that diagnostic tool and got this result:

    “v=spf1 +a +mx +ip4:69.195.124.159 ?all”

    This SPF record appears a number of times in the DNS records, once for each of a number of domains that my colleague runs out of our shared hosting service. For fun I added a new SPF record as specified in the MailPoet documentation for the specific domain on which I’m running MailPoet.

    I’ll let you know what happens.

    Plugin Author MailPoet

    (@wysija)

    Hi @cabrette,

    If you’re using our own sending service, you need to edit your existing record and include our sending service domain (include:spf.sendingservice.net) to the list of servers authorized to send on your domain’s behalf or simply remove the previous SPF record.

    If you add our domain, the SPF record should look like this:

    “v=spf1 include:mx.ovh.com include:spf.sendingservice.net ~all”

    You can change it on your hosting cPanel. There are guides to help you here: https://www.mail-tester.com/spf

    Plugin Author MailPoet

    (@wysija)

    Hi @markolbert,

    Yes, because you have already a previous SPF record for another sending service, you should add our domain to it.

    It should improve your deliverability and prevent the emails from being delivered under the Spam folder.

    Just make sure you have only ONE SPF record set up and it looks like this:

    “v=spf1 +a +mx +ip4:69.195.124.159 include:spf.sendingservice.net ?all”

    Let us know!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Emails Not Sending’ is closed to new replies.