Support » Plugin: bbPress - Anonymous Subscriptions » Emails not send when post are manually moderated

  • Hi Stefano “TheCrowned”,

    Great work you’ve done.

    My problem is that the anonymus subsription e-mails are only sent when I write a reply to an anonymus user’s post AS ADMIN. My reply isn’t moderated and is posted instantly. The anonymus subsription email goes then instantly to the anonymus user (the post author).

    But if I write a reply as an anonymus user (not logged-in), the reply goes to moderation queue. When I accept this reply as an admin manually (in dashboard (wp-admin)), the reply is then shown in the forum, but an e-mail is not sent.

    I have noticed in your functions.php this remark: “// Bail if topic is not published”. I am not able to understand it correctly, but maybe the problem is related to this manual posts/replies moderation.

    I use:
    WP 5.6 + bbPress 2.6.6 + bbp style pack + bbPress – Anonymous Subscriptions 1.3.7 + bbPress – Moderation Tools 1.2.4 + bbPress Topics for Posts 1.8.1 + Post Types Order + WP SMTP.

    Best wishes.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ste_95

    (@ste_95)

    Hey, sorry for the very late reply.
    Thanks for reporting this! Could you check if the anonymous subscribers correctly go into the list of users to notify? This is a postmeta called _bbp_anonymous_subscribed_emails, associated to a given topic/reply.

    A nice day,
    Stefano

    Thread Starter wrachtan

    (@wrachtan)

    Hi Stefano,

    Yes, in (phpmyadmin > …postmeta) there is ONE entry:
    _bbp_anonymous_subscribed_emails

    which contains all anonymus subsriptions.

    I’ve also noticed that it updates even if a post/reply is still moderated (not accepted yet) by the Admin.

    Best wishes,
    WRachtan

    Plugin Author Ste_95

    (@ste_95)

    Just a quick update to say I confirm the problem is there, but haven’t understood why it happens. Some more debugging is needed, but sadly haven’t had time lately…

    Thread Starter wrachtan

    (@wrachtan)

    Hi Stefano,

    I have a simple solution. Drink this:
    Time extender
    đŸ™‚
    I wish I could help, but I don’t know this php or whatever it is. And I also need the time extender.

    Best wishes.
    Wojciech

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Emails not send when post are manually moderated’ is closed to new replies.