Support » Plugin: MailChimp for WordPress » Emails not being subscribed

  • Resolved healthcongo


    Hi, I embedded the mailchimp signup form in my homepage, with the editor element. I made an API key and it showed the right mailchimp list, so thats fine, but when I fill in the form to test, I don’t get an verification mail and I don’t see the new subscriber anywhere added to my list in mailchimp. I tried to get it to work without the verification email, but that doesn’t work either..
    Am I missing something? Should I do something more in WP or Mailchimp to make this work properly?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • healthcongo


    Double opt-in is enabled.

    Plugin Contributor Harish Chouhan


    Hello @healthcongo,

    Can you please go to the “MailChimp for WP > Others” page and let us know if any errors are listed there?



    Hello @hchouhan

    No errors there. Thanks

    Plugin Contributor Lap


    It seems the signup is captured by sumo instead of our plugin. Are you using Sumo for something else? Else please turn off their plugin. If you need it for something you can ask them how to make it stop capturing the submits from other forms.

    Hope that helps. If you have any questions, please let us know!



    Sumo is integrated with the actual mailchimp account through the API key. So, I believe that regardless of the app that I use, emails should be captured to my mailchimp account.

    However the app doesn’t seem to work. The sumo app is also not capturing people who register to my mailing list through that app.

    I tested the Jetpack app, and that seems to send notifications. However, I don’t have a Jetpack mailing list account and would like to keep using mailchimp.

    I tested several emails with different hosting accounts and nothing has worked thus far with the mailchimp for wp app.

    NOTE: Please note that the mailchimp for wp app also was not working before I installed sumo. I tried sumo to see if I could get around this issue and still the same result.

    Please let me know if there is something else I need to configure or something that I am doing wrong?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Emails not being subscribed’ is closed to new replies.