Contact Form by BestWebSoft
[resolved] Emails not being sent (5 posts)

  1. alexgreen00
    Posted 1 year ago #

    Hi, none of my emails are being sent through. Ive tried switching the "The user's email address" to "Use this email address" options. Ive also tried switching wp-mail to php mail. Ive checked my junk folder.

    Im not sure why its not working. Iv'e tried using other contact form plugins and none of them work. Im also using the the Headway framework. If you have any ideas it would much be appreciated.

    Thanks, Alex



  2. bestwebsoft
    Plugin Author

    Posted 1 year ago #

    Hi Alex,

    Please follow the instructions below:
    1) email messages can be marked as spam on the server. Please choose another email instead of the admin's one ('Use this email:' block) - for example, gmail or similar. If the message is sent, it means that email filtering is set on your server.
    2) you should install an extra plugin called WP-mail-SMTP and configure it. Afterwards you should send a test email from this plugin and you will see if the plugin logs have errors. Please view the logs after sending a test letter WP-mail-SMTP and fix the occurring errors. Please pay attention, that it is necessary to set WP-mail-SMTP the same way your contact form is set before sending a message.

    BestWebSoft Support Team

  3. meowthecat
    Posted 1 year ago #

    Dear team,

    I've got the same problem. installed WP-mail-SMTP already and the test mail was fine. but still couldn't send anything from the from shown on web site.

    Is it any setting that I missed on the plugin? I use the code [bestwebsoft_contact_form lang=en] on page content. Is it the correct one?

    Look for your reply.


  4. Colectivo Sustento
    Posted 1 year ago #

    Ok, installed WP-mail-SMTP and test email to my yahoo address is fine, but still does not work from the contact form to this same address. Test email to address connected to webmail does not work at all.
    Look forward to reply.

  5. bestwebsoft
    Plugin Author

    Posted 1 year ago #


    Please try changing yahoo email to a different one - for instance, gmail or similar.

    This problem may be triggered by the SMTP server you've specified in WP-mail-SMTP settings (most likely, this is caused by your hosting's settings). Please try creating an account at Google mail service http://gmail.com (or use an existing account, if you already have one) and set up WP-mail-SMTP the following way:

    SMTP Host: smtp.gmail.com
    SMTP Port: 465
    Encryption: Use SSL encryption.
    Authentication: Yes: Use SMTP authentication.
    Username: Your Gmail Username
    Password: Your Gmail Password

    BestWebSoft Support Team

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form by BestWebSoft
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic