Support » Plugin: Peter's Collaboration E-mails » Emails No Longer Sending

  • Resolved barneskr

    (@barneskr)


    Hi there,

    My emails are no longer being sent to my inbox. WIth each of these plug-ins installed below, it was working until (I believe) the 3.9.2 update. Plugins:

    Admin Page Notes
    Broken Link Checker
    Disable Comments
    Duplicate Post
    Edit Flow
    Erident Custom Login and Dashboard
    Gravity Forms
    Inline Comments
    iThemes Security
    Peter’s Collaboration E-mails
    Peter’s Login Redirect
    Post Pay Counter
    Post Pay Counter PRO
    Screen Options and Help Show Customize
    SP Gravity Forms List & Edit
    Stream
    Subscribe2

    Can you help?

    https://wordpress.org/plugins/peters-collaboration-e-mails/

Viewing 8 replies - 1 through 8 (of 8 total)
  • We are having the same problem

    From your list, we also use Gravity Forms (extensively) and Peter’s Login Redirect.

    Have you had any luck?

    Thanks,
    -rich

    Plugin Author Peter

    (@pkthree)

    I tested this on WordPress 3.9.2 and I had problems with one mail server because it was blocking URLs in e-mails. (To test this, you can comment out all lines in the plugin file with get_edit_post_link in them.) However, on another mail server it was going through fine, so I couldn’t find any issues related to the plugin actually sending e-mails (and for that it uses the standard wp_mail() function).

    Perhaps a conflicting plugin is intercepting the transition_post_status filter and exiting, preventing other plugins from running in that filter.

    Thanks for getting back with me Peter. I’m certain it’s not the plugin because I disabled them all (except yours) and attempted to send an email — it did not work. I will try commenting out as you mentioned above and get back with you.

    Yep! That worked! The issue is with the mail server. So, is there any way around the issue?

    So, is there any way around this?

    Plugin Author Peter

    (@pkthree)

    I’m not sure why e-mail servers would have a problem with a link in an e-mail. Or maybe it’s a new feature in the wp_mail function.

    Obviously those links are important since they send the users to the correct edit paths. So as a quick patch you could replace all instances of:

    get_edit_post_link( $pce_object->ID, false )

    … with:

    preg_replace( '(https?://)', '', get_edit_post_link( $pce_object->ID, false ) )

    That will result in links without http:// or https:// in front, so they won’t be clickable.

    barneskr

    (@barneskr)

    This works perfect… and since gmail recognizes links I can still click. Thanks!

    barneskr

    (@barneskr)

    This works perfect… and since gmail recognizes links I can still click. Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Emails No Longer Sending’ is closed to new replies.