Support » Plugin: Subscribe2 » Emails for posts to subscribers stopped working

  • Resolved tjkpturner


    I have wordpress 3.5 subscribe 2 8.6 and jetpack 2.1.1 installed. I have the jetpack subscription options disabled.

    I’ve been using subscribe 2 for about 6 months and for many posts the emails have been going out great when I publish the post, but recently my public subscribers are not receiving emails, particularly on a post I sent out Saturday 1/5/13. I’ve checked and made sure my email to send from is correct and everything else I can think of. I tried the send email to my registered user to see if I could get one and it didn’t go. I don’t know what else to look for? Any ideas.

    Dreamhost is my host provider.

Viewing 15 replies - 1 through 15 (of 15 total)
  • @tjkpturner,

    You may need to contact Dreamhost about Subscribe2 and tell them you are collecting IP details as required by their internal policy for email based subscriptions. Dreamhost are and have always been very hot on stemming the tide of spam. I made some changes in version 8.6 of Subscribe2 to comply with Dreamhost’s requirements.

    They may need to speak to you to enable and increase your email sending capability.

    I sent the question to dreamhost that you had on another thread to ask about anything i need to do to make sure emails go through. They sent me this response (I since have sent the response you replied and havee received a response on that yet) –>

    Here’s there first response:


    The only way a web form would be restricted on our servers is if the FROM
    address is not valid. Here is our status post about this:

    Basically it states that if a form is on a website such as,
    the FROM address in that form must remain static and non-changing.
    Something like If it’s anything else our SPAM filter
    will catch it and nothing will be sent.

    If you want to use another FROM address you’ll need to use an SMTP plugin
    for that other mail host to allow it to pass through our SPAM filter
    properly. Please let us know if you have any further questions.

    I meant above that I haven’t received a response from them yet about enabling and increasing my email ability.

    Anotehr question. I have two administrators set up. I send from one that has my dadfirst email address and the other is my personal email, I only need to make sure that I’m sending from the one that uses the dadfirst address correct and it should work?


    Okay, so you have 2 administrator level accounts with different emails, 1 that is an email address on your blog domain, the other is not.

    Go to Subscribe2->Settings and look for where it says “Send Email From:”, then in the dropdown list at the side select the account name that uses the on-domain email address. You could then test by manually sending an email to your Registered Subscribers again.

    I have the user(administrator) set up that I’m testing with the on-domain email address and have that as the user to send “Send Email From”. Still nothing. I sent a test to all my subscribers both registered and public and nothing is going through.

    Is there a way I can go back to version 8.5 and see if it works and then install 8.6 to see if that is really when the problem came into play. Its worked for many months and I’m fairly certain that is the only variable that changed.


    You can download all of the previous version from here:

    Reverting to version 8.5 should not have any impact on database entries and is fine to do.

    While the update is the only thing YOU change it’s almost certainly not the only variable that changed. Hosting providers are always tinkering with their server setup, most of this is transparent but sometimes it opens up new issues like this. I’d still recommend talking to Dreamhost.

    I sent you latest question to dreamhost you suggesteded and still waiting for a response on that.

    As far as reinstalling, if you think its worth it, how do I actually do that? Do I delete it and then install it again from wordpress? My subscribers won’t get last if I do that.

    Forgive me, I’m ok with working on this, but I’m not a programmer so I just don’t want to svrew this up more.

    Thi is what I just got back from dreamhost… not very helpful. I did have a couple emails that went through. One to my comcast email address. But I have two subscriber I know didn’t get anything at a gmail address and roadrunner. I did reply to them that these emails were not getting emails.

    Here is dreamhost, latest response:

    If you are using as the sender, your plugin should work
    properly. What is the issue you are having? If the problem persists,
    please let us know as much detail as you can including any steps to take
    to replicate the issue. This will allow us to better assist you! If you
    need to submit your WordPress login credentials, you can by submitting a
    new support request and fill the credentials in the appropriate fields.

    If there is anything else you need help with, please let me know! Thanks!
    Have a great day!

    Anthony S
    DreamHost Support


    To revert to a previous version use FTP (DO NOT use the WordPress admin area or you will erase all of the plugin data including your subscribers). Upload the new files after erasing the old subscribe2 folder.

    As for progressing things with Dreamhost, I’d recommend you install a mail logging plugin to WordPress, if that shows that the emails are being generated then the server is blocking them. If they don’t show in the log then it’s a Subscribe2 configuration issue or a plugin / theme conflicting with Subscribe2.

    I installed Email plugin. It shows me the test email when I go to settings, but just one email is listed. How do I access the database table to see who actually all got the emails? Or is just seeing one entry per email good enough?

    I did get notification and know that some subscribers are getting emails and others are not. I’m getting them to 2 different emails, one gmail and one comcast, but my wife does not at her gmail. What is going on?

    I received this from Dreamhost support. It appears as I have found that many of the emails are getting through, but some are not, particularly my wife’s email and a couple others at gmail, I know of, but my gmail is getting through.. So if he can’t see the emails getting created for some of the addresses, but everything looks right, then do you have any other ideas?

    Latest Dreamhost response –>

    Hi Friend!

    I looked over your Subscribe2 settings and didn’t notice any issues.
    Emails sent from your site that cannot be delivered are not lost, but
    bounce back to the server user who hosts the site that sent the email.
    You can view them (they are just text files) in the Maildir/new and
    Maildir/cur directories on the webserver. I reviewed a few of those to
    find out more information about what’s happening.

    Some emails that were sent from your site and not blocked by our policy
    were rejected by the recipient mail servers. This situation is a “mail
    block”; Hotmail and mail servers are blocking all emails
    sent from an IP address used by one of our mail servers. We do care
    about this immensely, and have a Mail Block team that works on these
    issues constantly. Our Mail Blocks Team is in discussion with the
    blocklist maintainers with regard to this, and we are hopeful we can
    prevail upon them to remove the block soon. I will leave this support
    request open and move it to their attention, so they can use it in their
    efforts to have the blocks lifted.

    I did not find any record of emails sent from your site to
    <>. If you have any other questions or issues, please
    let me know, I’m always happy to help!

    Ereon! Dreamhost..

    — This is TJ again, thank you for your help with this, I’m sorry its taking so long to resolve… i just wish I knew why some are getting generated and others aren’t


    Go to the Subscribe2->Settings page under the Email Notifications heading and look where it says:
    “Restrict the number of recipients per email to (0 for unlimited):”, if this value isn’t ‘1’ then change it to ‘1’.

    Save the settings.

    Next visit the Templates tab and click the “Send Email Preview” button. Then check the email log, there should be 4 emails in there if you are sending notifications ‘per-post’ or one if you are sending a digest based email.

    If all that works then the most likely reasons for your emails going missing is that the email address is not fully subscribed (maybe unconfirmed public or a Registered User who has no subscribed categories) or spam filters on the recipients server (i.e. GMail).

    Thanks, I’ll change the recipients. Question though, I thought it had to be 0 for everyone to get all the emails, do I need to change it back after this test?

    I only had 1 email after following your instructions in the log and I have it set to Per Post send notifications so shouldn’t there be 4?


    No, if it’s 0 then 1 email is sent with all of the recipients in the BCC email header. This looks very much like spam to many hosts now so the default install value there has been 1 for quite a while.

    With a value of 1 the emails are sent individually to each subscriber, so if you have 203 subscribers you will generate 203 separate emails.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Emails for posts to subscribers stopped working’ is closed to new replies.