Support » Plugin: Membership 2 » Emails dont work

  • Hi!

    I have a problem with the plugin. The automated email responses dont work, and when a user buy a membership, doesnt receive anything.

    This is a problem because I need to send an email with instructions on every purchase and it seems that the user hasnt bought anything.

    I tried to deactivated “Use WordPress Cron for sending emails” but it doesnt work either.

    I tried to install the plugin Check Email and the emails is ok…

    Please, is urgent…

    • This topic was modified 1 year, 7 months ago by jcarlosc.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hey there @jcarlosc,

    hope you’re doing good today! 🙂

    Could you please inform me about the exact email you’re referring to?

    In the first payment of my testing user, I got the “Payment – Receipt/Invoice” email (used Stripe sandbox for payment).

    Also try to deactivate the Enable account verification option in Membership -> Settings -> General and try to register a new user.

    Finally, please ensure there’s no other plugin/theme affecting this.
    Install “Health Check”: https://wordpress.org/plugins/health-check/
    On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Warm regards,
    Dimitris

    Hi Dimitris.

    The Payment – Receipt/Invoice its ok, but before that, the software should send an email of thanks and with instructions to access the course that I created.

    Enable account verification it has always been disabled.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @jcarlosc,

    Hope you’re well.

    Can you please let me know which email template is not working? So I can test that email template exactly. Also, can you check is that email looks enabled like this;

    Cheers,
    Oguz

    My email template look like this:

    </img>

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hey there @jcarlosc,

    hope you’re doing good today! 🙂

    Just made some more tests on this and I was able to recreate the same issue.
    Subscription – Completed with payment emails aren’t sending off, despite if I use Paypal or Stripe as payment gateway.

    I’ve already created a bug report for our developers.
    Me or another colleague of mine will keep you posted here about any development.
    Meanwhile, you can make use of the Payment – Receipt/Invoice email and keep an eye in your dashboard for any plugin update (always keep in mind to backup your site, before proceeding with any updates).

    Warm regards,
    Dimitris

    Hello, Dimitris.

    This problem for us is urgent to be able to solve it.

    When will we know something?

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @jcarlosc,

    Hope you’re well.

    Our developers testing some cases and working on that, but we can’t give any ETA for the update. But we can update this thread when the update or any information about the problem available.

    Cheers,
    Oguz

    @jcarlosc I came across the same thing and downgraded the plugin, a newer version has broken email sending.

    Thanks James!

    But where can I download an earlier version or how can I downgrade it?

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Old versions can be downloaded from here:
    https://wordpress.org/plugins/membership/advanced/

    You can simply connect to your server via FTP and replace the /wp-content/plugins/membership/ folder with the older version.

    Ok thanks!

    I’m having the same problem. which version did you switch to?

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @webmasterbwaorg

    Hope all is well!

    Please download and manually install the previous version of the plugin, which is 4.1.2

    If you will have any further questions, please open a new ticket in our forums.

    Have a good day and take care!

    Cheers,
    Nastia

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Emails dont work’ is closed to new replies.