Support » Plugin: WP Mail SMTP by WPForms » Emails delayed or not received

  • Resolved sw231

    (@sw231)


    Hi,

    We have been using your plugin for sometime but we are having issues with emails either taking hours to be received or not being delivered at all. We can see from the email logs that they have been sent but they are not being received.

    We have just deactivated your plugin and now all emails are being received almost immediately. Has anything changed since the last update or are there some settings that we need to update?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello I’ve been having a similar issue. I originally posted a help thread on the ThimPress Coaching Theme support forum. This link is a PDF of the forum thread since it’s only visible to registered users of the support system.

    https://www.dropbox.com/s/n11hw5cf23jgg5b/WP%20Mail%20Forms%20not%20working%20-%20ThimPress.pdf?dl=0

    The tech (Daisy) at first wasn’t able to recreate the error, and said it was working fine, but then after I got more complaints from users about emails not coming through, I asked her to investigate if it was happening with mobile users (rather than desktop users) and she said she was able to create the error of emails not being delivered. She then directed me to reach out to WP Mail Form directly.

    Thank you for creating this great app!

    P.S. In case it helps trouble shoot, I’m using WP Mail SMTP Pro configured to work with Office 365 through GoDaddy.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @sw231 and @dreynald,

    could you please let us know which mailer you are using (in our plugin settings)?

    It’s also important which emails are not being delivered (test emails, contact form emails, some other ones?) Which plugin is sending them. Maybe they have a delayed sending technique.

    Maybe the mailer you are using had a temporary issue and the emails were delayed (not delivered) from their side?

    Our plugin does not have any queueing system, so the emails are sent to the configured mailer, which then actually sends the emails to the recipients. Some of the mailers have their own email logs, which you can check and see if the email request was received and if the email was sent/delivered.

    Please let us know more information, so we can investigate and help you.

    Have a nice day!

    Thanks Gregor! I’m using the Microsoft Outlook Mailer. I get test emails, but it’s contact form emails sent by website users that aren’t coming in. In my case, the emails never came through, nor did they ever appear in the email log I activated.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @dreynald,

    hmm… if they didn’t appear in our Email Log, then they weren’t sent from our plugin. It might be that you have some other email sending plugin installed and it’s conflicting with our plugin (taking over the email sending)?

    The failed emails would have to be in our Email Logs if something went wrong with sending, but no email log entries is a bit strange.

    Could you please provide a list of all active plugins. You can get that from Tools > Site Health in your WP dashboard, select the “info” tab and then you will see an “Active plugins” section.

    Take care!

    Thank you, Gregor! I’m using:

    Autoptimize
    Black Studio TinyMCE Widget
    Contact Form 7
    LearnPress
    One Click Accessibility
    Page Builder by SiteOrigin
    SiteOrigin Importer [Beautiful]
    SiteOrigin Widgets Bundle
    Thim Core
    Thim Our Team
    Thim Testimonials
    W3 Total Cache
    WP Encryption – One Click SSL & Force HTTPS (Premium)
    WP Mail SMTP Pro
    WP User Avatar
    WP-Optimize – Clean, Compress, Cache
    Yoast Duplicate Post
    Yoast SEO

    (And all plugins are up to date)

    Thread Starter sw231

    (@sw231)

    Hi Gregor,

    Thanks for your reply. After further discussions with our host I think the issue may have been down to them changing our website servers so the settings were not matching up. Apologies for raising the issue as it doesn’t look like it’s down to your plugin.

    Cheers,

    Rob

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi Rob,

    thank you for letting us know!

    Have a nice day!

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @dreynald,

    It seems that you are using the paid version of WP Mail SMTP (Pro version). When you have a chance, could you please submit a support ticket through the WP Mail SMTP account dashboard?

    From there, our support team will be able to take a closer look, with more details at your request. You can also reference this thread in the new private ticket you will create, so our team will have some reference to the issue.

    Thank you and have a nice day!

    Will do, thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.