Support » Plugin: Subscribe2 - Form, Email Subscribers & Newsletters » Emails being sent despite Disable Sending box being checked

  • Resolved dminghella

    (@dminghella)


    Hi this is a weird one. Been using Subscribe2 happily for years.
    Disable Sending is set to default, as I only rarely wish to bother my subscribers.
    However, recently the plugin is firing out emails regardless.
    I used to think it only happened if I checked in the post editing page to confirm that Disable Sending was checked but today emails were sent without me checking. (And in all cases the Disable Sending box was checked, as I have it set in the plugin’s settings.)
    Any wisdom, folks?
    TIA

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mattyrob

    (@mattyrob)

    @dminghella

    I’m presuming you are saying that the Disable email notifications is checked by default on authoring pages? setting in the Subscribe2 > Settings page under the Appearance tab is checked. And that when you check in a post before hitting Publish, that it is checked in the display there too.

    Are you using the Block Editor, or Classic? Is this via a plugin?

    I presume you are getting the notification yourself which is how you know this is happening – right?

    dminghella

    (@dminghella)

    Correct on all presumptions.

    Using block editor, and typically Classic Paragraphs and Image blocks. Here is a post which went out despite all the correct settings. https://www.minghella.com/we-voted-three-times-to-leave/

    Much appreciated @mattyrob if you can identify the issue.
    TIA

    Plugin Support mattyrob

    (@mattyrob)

    @dminghella

    I’ve tested on a local install of WordPress 5.2.3 and I’m not seeing any issues. If I manually over-ride a post no email gets sent and if I have that option checked by default, again no email is sent.

    When you open new or existing post in the Editor, are you seeing an errors reported in the Browser Inspector?

    dminghella

    (@dminghella)

    No errors. Only 4 warnings.
    onmozfullscreenchange is deprecated. components.min.js:12:80764
    onmozfullscreenerror is deprecated. components.min.js:12:80764
    MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead. tinymce.min.js:2:9046
    Source map error: request failed with status 404
    Resource URL: https://www.minghella.com/wp-includes/js/tinymce/skins/lightgray/skin.min.css?wp-mce-4940-20190515-tadv-5210
    Source Map URL: skin.min.css.map

    Plugin Support mattyrob

    (@mattyrob)

    @dminghella

    They shouldn’t be causing too many issues, when you click the checkbox do you get any new errors showing? (Also what browser are you using?)

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.