Support » Plugin: WPCargo Track & Trace » emails not being sent

  • Resolved vallatest

    (@vallatest)



    Hello all
    I noticed that emails are not sending when I add or update shipment. Other emails from wordpress such as new user emails are working.
    Please assist me in fixing this.
    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hey,
    not to worry. I have it rectified it. it works!

    same issue on my site too, @vallatest can help me? How did u solve that?

    login, go to your wp-cargo email setting, scroll to mail-to: and use tags provided at the top in red colour. that’s all.

    Plugin Author Arni Cinco

    (@wptaskforce)

    Hi @vallatest Thanks for the help!

    @nafi121 Please check the solution of @vallatest if its work for you. Thanks!

    Hi @nafi121 The plugin email suddenly stopped working again. All the settings are correct. What could be the reason?

    i guess its a bug or whatever, when ever i try to track a shipment it keep on sending tracking details email but when open email dont have details actually

    Hi @wptaskforce The plugin email suddenly stopped working again. All the settings are correct. What could be the reason?

    Plugin Author Arni Cinco

    (@wptaskforce)

    The email functionality is when the status is changed.. for example the current status is Pending and changed it to Delivered it will send emails.

    So if the current status is Pending and you update your shipment with no changes on status it will not send..

    If you want to modify it its on the WPCargo->admin->templates->email-notification.tpl.php

    @wptaskforce I mean when shipment is created and also when the status changes. It worked when I first installed it but stopped working even if i change the shipment status.

    Plugin Author Arni Cinco

    (@wptaskforce)

    @vallatest Please make sure your header settings on email is on “User <user@example.com>”
    For more info about mail please refer to this – https://developer.wordpress.org/reference/functions/wp_mail/#valid-address-formats

    Thanks!

    Woedpress 4.7
    WP Cargo Version 3.0.8

    Mail is not working when the shipment is created, nor when the status is changed…???

    is there an issue with the plugin on 4.7?

    ~Respect

    Hi Team emails or not working in my Website when i created shipment, it will not send and receive any mail.

    Sagar

    We are using this PHP version is 5.6 is this problem for not sending mails.

    Plugin Author Arni Cinco

    (@wptaskforce)

    Hi @wildbuttrueblue and @vidyagsagar123

    We update the version to 3.0.10
    Fixed the issue on notification email after updating. If you are adding a new shipment there is no email notification, For the newly added shipment the email notification works when the status is updated or changed.

    And please make sure your headers is based on your domain it is on email settings of wpcargo.
    For example WPCargo <do-not-reply@wpcargo.com>
    And also use the tags if you want to send email on the shipper or receiver, that is also can be seen on email settings of WPCargo.

    Thanks!

    • This reply was modified 1 year, 11 months ago by  Arni Cinco.
    • This reply was modified 1 year, 11 months ago by  Arni Cinco.
Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘emails not being sent’ is closed to new replies.