Support » Plugin: Post SMTP Mailer/Email Log » Email working, but can I show “noreply@mydomain.com” instead of my smtp email?

  • Hi
    This is a newb question

    I would like to show “noreply@mydomain.com” on emails sent from my website, instead of showing “myemail@mysmtpemail.com”.

    How do I do this? I am using infinityfree for my first site, and I think it would look better to have emails sent from my contact form to show the domain name not the smtp email domain and user.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I have the same problem.

    Plugin Support Tim

    (@tneville)

    Hi @apartmani1,

    You can change the sender email address in your Post SMTP settings. In your WordPress admin dashboard, go to: Post SMTP > Post SMTP > Show All Settings > Message > Email Address. This should affect all mail sent via Post SMTP.

    Be aware that you need to update your SPF on the domain that is your envelope-from address. If they don’t match, your emails may go into recipients spam/junk folders.

    For your future reference, please start a new thread and link to this one – as this is an old thread, there may be occasion where your request is missed and does not get a reply.

    Does that help?

    Kind Regards,
    Tim

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.