Support » Plugin: Contact Form 7 » Email with blank form sent

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Any help on this??

    @camscorner – if you need more assistance than the link given by Takayuki that covers your problem, please include a link to your Contact Form 7 form plus all your input in the Form and Mail sections of the CF7 interface.

    Okay, I clicked on the link & it’s probably my ignorance but I don’t see an answer here.

    Here is a link to my form. http://cathymiller.biz/contact-cathy/ and what I input into Form.

    <p>Your Name (required)
    [text* text-391 id:YourNamerequired]</p>

    <p>Your Email (required)
    [email* YourEmailrequired]</p>

    <p>Your Company
    [text your-company]</p>

    <p>Company Website
    [text company-website]</p>

    <p>Services You are Interested In (check all that apply)
    </p>

    <p>[checkbox checkbox-744 id:RequiredServicescheckallthatapply label_first use_label_element exclusive “Consulting” “Business writing ” “Ghostwriting”]
    </p>

    <p>Description of Project or Information You Need (required)
    [textarea* DescriptionofProjectorInformationYouNeedrequired] </p>

    This is what’s in “Mail”.

    To: cathy@cathymiller.biz

    From: [your-name] <[your-email]>

    Subject: [your-subject]

    Additional Headers: Reply-To: [your-email]

    Message Body: From: [your-name] <[your-email]>
    Subject: [your-subject]

    This e-mail was sent from a contact form on Cathy Miller (http://cathymiller.biz)

    <p>[submit “Send”]</p>

    For some reason, the link isn’t working to the form–trying again

    http://cathymiller.biz/contact-cathy/

    Okay, I just tested the contact form and it is sending blank requests (even though it worked fine in the past)–???

    Through much trial and error and research on my own, I resolved this.

    @camscorner – I see you solved your problem before I got back to you.

    ​​Looks like you may not have changed the Message body: field in the Mail section of the CF7 interface from the default values.

    The Mail tags you use in Message body: field need to match up with Form tags you use in the Forms area in order to see these values in your email.

    If your question is resolved you can flag your post as [resolved]​​

    This was the simple response I was looking for. Thanks.

    Received an email from someone who did not understand the solution.

    Basically, you click on the Mail tab and make sure you use the same tags [information in brackets] in the Message body as you have in the Forms tab.

    Example:
    MAIL Tab:

    To: enter the email address of where you want the form sent
    From: Use same tag that was used in the FORM – in my case it was: [text-391] <[YourEmailrequired]>
    Message body: Again use the same tags that were used in the FORM
    In my case it was:

    From:[text-391]<[YourEmailrequired]>
    Company:[company-website]

    Services:[checkbox-33]

    Message Body:
    [DescriptionofProjectorInformationYouNeedrequired]

    TIP: When you click on the Mail tab, it shows your unique tags at the top. For example, mine shows:

    Mail
    In the following fields, you can use these mail-tags:
    [text-391][YourEmailrequired][your-company][company-website][checkbox-33][DescriptionofProjectorInformationYouNeedrequired]

    You can then place them where you want them in the Mail. Hope this helps.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Email with blank form sent’ is closed to new replies.