Support » Plugin: Email Users » Email Users, s2member and WP-SMTP-Mail

  • Resolved bullandbearmash

    (@bullandbearmash)


    Using latest versions of all 3. About 4200 subscribers. Email limit verified raised by provider to 5000. BCC field set at 30.

    With all plugins running:

    Send test email through emailusers – PASS

    Send test email through WP-SMTP-Mail – PASS

    In production: using the “send email to individual users”, highlight all users, enter subject, enter content. Click “send email”

    System responds with these error messages:

    You must enter a subject.
    You must enter some content.

    Have tried the “send to groups” – same parameters. Same error messages.

    Please help.

    https://wordpress.org/plugins/email-users/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    When you get any the “you must enter …” error messages it means that something, likely another plugin, has squashed the $_POST data which is expected when the form is submitted (when the “Send” button is pressed).

    I would do a couple things:

    1. Don’t test your email with all your users until you know it is working.
    2. Create 2-3 “test” users (this is a great use of Gmail’s “+” feature in the email address: myname+test1@gmail.com, myname+test2@gmail.com, myname+test3@gmail.com, etc.) where you can send email to yourself to verify everything is working correctly before sending it to your entire user base.
    3. Disable all plugins except Email Users and your SMTP plugin and make sure Email Users is working correctly.
    4. Enable S2Members and test again.
    5. If everything is working at this point, I would then enable other plugins one at a time until it stops working. Always target your test addresses instead of your users. The problem you’re facing is not affected by the number of users selected.

    Hope that helps – that is where I would start to see what is wrong.

    bullandbearmash

    (@bullandbearmash)

    I understand your approach to isolate the issue.

    Have you ever seen this “…squashed the $_POST data …” error in the past?

    Aside for the approach, what was the bottomline issue that was uncovered?

    bullandbearmash

    (@bullandbearmash)

    I also neglected to add that your comment “… The problem you’re facing is not affected by the number of users selected. …” is incorrect.

    I have been able to send in batches of 200 without error and confirmed sent by the SMTP provider and received by 2 users within the group of 200.

    So it does appear that this size of the send is directly related to the stability of the send.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    If you are able to send in batches of 200, it is possible that when you select all 4200 users, the length of the resulting string is too long for the POST operation to work correctly.

    This can vary based on browser and web server. Is there a reason you wouldn’t use a group to send to that many recipients?

    Unfortunately all of the debug code I’ve added (which can be enabled) happens after the POST operation is performed so that doesn’t help us here but if you’re willing to load a beta version, I can add some additional debug code to look at the POST data when the form is submitted.

    A tool like Firebug would also be useful for looking at the POST data when the form is submitted to see what is happening to it. Actually, this where I would probably start first. Firebug is incredibly useful for problems like this. Unfortunately I don’t have anything readily available which has that number of users to test with at the moment. I will have to dust off the Test User Creation plugin I wrote for my Swim Team plugin but I won’t be able to do that today, possibly over the weekend.

    I would put Email Users in DEBUG mode (Dashboard > Settings > Email Users – check the DEBUG box) to that you can do some testing with your entire user list without worry about sending them any email (email is never actually sent in debug mode).

    bullandbearmash

    (@bullandbearmash)

    This has been a long process for me up to this point – pardon not disclosing that I tried emailing from a “group” instead of “users” and the system produced the same error as mentioned above.

    I loaded firebug into firefox 27 (this version fails the least). What specifically would you like me to make note of?

    Beta version? Very open to this – ready when you are.

    Would you like me to post “debug” from email users here? Can email too.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Unless you want to provide me a login on your site, probably the next step is for me to generate a whole bunch of test users so I can try and replicate the problem you are having. This being Thanksgiving I have some time off from work the next couple of days so I will try and do that and report back what I find.

    If you’ve never used Firebug before it isn’t something which is easily explained via the WordPress forum. If want to poke around with it, the “Net” tab can show the status of a POST or GET request and let you dig into the actual headers sent to the server.

    bullandbearmash

    (@bullandbearmash)

    I can email up to about 500 subscribers as “users” at a time. Anything more I get the error messages mentioned above.

    Just emailed in batches and everything works fine.

    There appears to be a limit in the system – after around 500 recipients, the system fails.

    My provider set my “BCC” at 1000 – I have it set at 250 internally.

    I don’t think it makes sense to create a bunch of test users unless creating 500 is an easy task – I suspect it isn’t.

    If you can direct me to create a log, I can send you a log that shows a failure. Would that help to isolate the issue?

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I don’t think the issue is around the BCC limit, I think it has something to do with the amount of data being submitted with the form when you initiate the send request.

    Couple of questions (if you know the answers):

    1. What version of PHP are you running?
    2. Is your server running on Linux or Windows?
    3. What server software are you running (Apache, Nginex, IIS)?

    I wrote a plugin a couple years ago that bulk creates dummy users. I haven’t run it in a while so I just need to look at it and see what has changed in WordPress to make it run. If it still works, creating hundreds of dummy users is a couple minute task.

    bullandbearmash

    (@bullandbearmash)

    Noted on the bcc suggestion – didn’t think so either, but it’s now disclosed.

    answers:

    1. php interpreter for versions 5.2 to 5.5
    2. centos 6 – 64b(linux)
    3. host says both apache and nginx (on a shared nginx)

    Would you like to attempt guiding me to create a log for you?

    bullandbearmash

    (@bullandbearmash)

    Just a quick note Mike – I was successful with a 960 recipient send.

    I tried a larger one and the same error message as above appeared.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I have replicated this problem in my development tree. Now I need to see what is causing the problem. Stay tuned …

    bullandbearmash

    (@bullandbearmash)

    That’s wicked Mike!! Great news!!!

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I did some debugging on my flight to Chicago this morning, will continue on my next flight to Portland.

    This issue is caused by the PHP configuration setting MAX_INPUT_VARS which defaults to 1000. If you change it in your PHP.ini file, which may not be possible in many hosting situations, to a number larger than your max user count plus 10, the problem will not occur.

    What I am doing is adding some checking logic to the plugin so if this situation is present, a warning will be displayed on the Dashboard when sending email. I already have it working for the “Send User Email” case. I am working on the “Notify Users” case. Once complete, I will upload a new version, likely later today.

    The reason you can’t send to exactly 1000 users is because there are other fields in the form which consume some of the MAX_INPUT_VARS slots.

    bullandbearmash

    (@bullandbearmash)

    there is a php.ini file, (assuming you mean same as PHP.ini)

    no reference to MAX_INPUT_VARS within this file

    look forward to your update

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I have posted beta-1 of v4.7.0 on my site along with an explanation of the problem.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Email Users, s2member and WP-SMTP-Mail’ is closed to new replies.