Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » Email test successful (from dashboard) but no emails from form

  • Resolved dayte

    (@dayte)


    The Setup Wizard of WP Mail SMTP checked OK for the mailer configuration (using Sendinblue as the mailer option) and the test emails sent from the dashboard are delivered, however, emails sent by using the web form are not delivered although Notifications are “on” and every field is set with a valid value (in particular, “Send To Email Address” is set to {admin_email} while “From Name” and “From Email” are forced by WP Mail SMTP settings).

Viewing 8 replies - 1 through 8 (of 8 total)
  • same as me. But I’m using the free one. Still got same issues.
    didn’t received email from the website

    Thread Starter dayte

    (@dayte)

    I am using the free option as well, but the oddest is that emails are delivered if the form used is built with Formidable Forms plugin instead of WPForms plugin (WP Mail SMTP settings untouched)

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hey @dayte,

    Sorry for the trouble with that!

    When you get the chance, could you share a screenshot of your form notification settings here?

    @asri123, could you please create a new post in our support forum when you can?

    Thanks!

    Thread Starter dayte

    (@dayte)

    Hi @ethanchoi,

    Thank you very much for replying, here you can find a screenshot of the form notification settings.

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hey @dayte,

    Thanks for the update!

    It looks like the form notification settings are correct, so there are a couple other settings we can look at.

    1. Navigate to WPForms > Settings > Email, if the Optimize Email Sending option is selected, could you try deselecting it to see if it helps resolve the issue?

    2. You could also check that your WordPress admin email is configured by going to your WordPress admin sidebar > Settings > General

    Please let me know how it goes!

    Thread Starter dayte

    (@dayte)

    Hi @ethanchoi,

    deselecting the “Optimize Email Sending” option solved the problem, however, since it offers the possibility to improve performance, I would like to be able to check it, is that possible?
    Thanks for your time and attention!

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @dayte,

    With “Optimize Email Sending” selected, notification emails from the form will still be sent. However, this will be done asynchronously, which means the email sending tasks are placed in a queue in the background so other form processes can be processed faster.

    Also, site activities will push the queued email sending to be executed. As your site traffic increase, you may notice that email sending becomes faster.

    So if you’d like to, it is still possible to enable this option.

    Alternatively, you may want to check out this WPBeginner article for tips on improving the performance of your site.

    Hope this helps!

    Thread Starter dayte

    (@dayte)

    Thank you very much!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.