• Resolved kiskrtek

    (@kiskrtek)


    Hello,
    I changed the email templates in the admin page but they are still sending the original templates.

    I tried to add to the child theme too, but I can’t find the original templates I can add to the paid-memberships-pro/email folder. Where are the original email templates located? I have no “email” folder in the /plugin/paid-memberships-pro folder.
    Thank you

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Kim White

    (@kimwhite)

    Hello @kiskrtek,

    Email template files are no longer stored in a folder. Instead, the content is stored in your database but can be changed from the PMPro admin area.
    https://www.paidmembershipspro.com/documentation/member-communications/customizing-email-templates/

    Are you changing your templates on the Memberships > Settings > Email Templates page?
    http://yoursite.com/wp-admin/admin.php?page=pmpro-emailtemplates

    When you change them here, are you able to send a successful test email from this page?

    If you are making changes to the email templates and not seeing the changes, do you have caching enabled on your website?

    Any additional information you can provide would be helpful.

    Kim W

    Thread Starter kiskrtek

    (@kiskrtek)

    Hello Kim,
    I set the templates in Memberships > Settings > Email Templates page.
    I can send test emails, but the system is not sending the new emails I set there at the ’email templates’ page, but sends the original emails. My emails are translated and changed and the system still sends the original English emails.

    I don’t understand, because the subject is changed but not the body part.

    I also use loco translate in my website, can it be any issue with this?

    Plugin Support Kim White

    (@kimwhite)

    Hello,
    I’m sorry this is not working as expected. Can you provide me with your Site Health Information? You can copy and paste this from the Site Health info page.

    Thank you,
    Kim W

    Plugin Author Andrew Lima

    (@andrewza)

    Hi @kiskrtek,

    I am helping Kim with this ticket. Once you have edited the email template via the editor and save the template they become untranslatable because this data is now stored in the database so services like LocoTranslate won’t be able to translate the emails.

    You would need to hook into the pmpro_email_body filter to tweak the content and translate it manually via code based on the locale used. Here is documentation regarding the filter – https://www.paidmembershipspro.com/hook/pmpro_email_body/

    Alternatively, you may leave your emails unedited (reset the templates) and these will then support translations.

    • This reply was modified 7 months, 1 week ago by Andrew Lima.
    diegoarg

    (@diegoarg)

    The same thing is happening to me. Changes only apply in the subject, but not on the body of the email. I see it on spanish in the editor, but emails are always sent in english. Reseting emails templates doesn’t help. The problem is not the translation, the editor doesn’t work, plugin always uses the original unedited english email.

    Thread Starter kiskrtek

    (@kiskrtek)

    I reseted the tempalte to the original (without translation) and changed the template. But it is still sends the original emails.

    So after I changed the template one time I am not able to change it again in the template editor only via hooks?
    Thank you!

    Plugin Author Andrew Lima

    (@andrewza)

    The Email Template Editor only supports single locale’s and not multilingual sites. If you need to tweak the email contents with various translations you would need to do one of the following:

    1. Reset the template and then let your localization plugin handle translations and translate it for all instances.

    2. If your email template is adjusted already, localization won’t work as it’s now stored in the database as an option and not a translatable string. You’d then need to tweak this via a hook.

    I haven’t been able to replicate the issue of the body contents not changing when it’s suppose to. What I can recommend is to test this with only Paid Memberships Pro enabled and no other plugin to ensure there’s no conflict. @diegoarg if you’re still facing issues, please open a new support ticket here with more information about your issue and feel free to share your Site Health Debug information so we can try and replicate this issue to ensure it’s a bug and not a site-specific issue.

    ltrost

    (@ltrost0910gmail)

    I spent all weekend struggling with this where the email template changes are not saving, test emails are being sent but empty, on admin editor it goes blank, etc. Very erratic. But I think I’ve just found something that may explain it, at least in my case. I was putting an html comment in such as <!– test me –> and it seems to blow up the body of the email and blanks it out after I send a test email. SO DON’T ENTER COMMENTS! Not sure if this will help anyone else but I thought I’d post it. Good luck!

    ltrost

    (@ltrost0910gmail)

    Blah! No comments in code, no syntax errors, but still finding erratic behavior with the Email Template editor erasing whatever I have entered. This is very irritating.

    ltrost

    (@ltrost0910gmail)

    I now realize that I had the Email Template add-on activated. The current PMPro has incorporated that functionality into the core, and can now be accessed under PMPro settings/email templates. It seems to be working correctly now.

    Hello, I don’t know if it’s related but I also have problem with the emails translation.

    My website is in french, everything is in french and the emails sent are in french BUT when I want to edit the email templates, PMPro only shows me the english templates.
    If I make changes in them, it doesn’t affect the mails sent because I edit the english emails and the french are sent…

    How can I force PMPro to show me the french email templates in order to be able to edit them ? I tried the code above but it doesn’t change anything… .

    Thank you

    Hello,

    Any idea ?

    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.