Support » Plugin: Wordfence Security - Firewall & Malware Scan » email summary report not being produced or sent to me – part 3

  • Resolved lar

    (@larclericalpluscom)


    as per where we last left off (i told you i would get to it. . . granted it took me 2 plus weeks) . . . you wfpeter last wrote:

    I see you’ve already tried quite a few methods of trying to fix this. One thing that springs to mind if you’re receiving other Wordfence/WordPress emails successfully is whether the scheduled cron job is running. Could you check whether the “wordfence_email_activity_report” value in Wordfence > Tools > Diagnostics > Cron Jobs shows a recent date?

    today i had some time to burn, as i thought this would kill at least an hour . . . and this client with the wordfence report problems has managed wordpress hosting at godaddy . . . and we all know how painful that is!

    thus i couldn’t perform or view anything, since his hosting is locked down more than the capital

    i started a chat, and i informed the tech of what was happening and what you told me to do – a direct cut ‘ paste of your request verbatim

    and she replied:
    Thank you for waiting Larry. Your hosting account is all set and in shared hosting platform, we or you cannot configure the cron job modules due to system limitations.

    and i replied:
    i understand that
    the tech was asking for a date value
    what does is say?

    and she replied:
    We cannot check the date value as you are on shared hosting platform.

    end of story (i then bitched that i understand godaddy’s security policy, but they are way too restrictive as compared to many past/current hosting companies, and are not cheap, and that’s why i, and many other of my clients have left their hosting)

    1 hour and 7 minutes for that . . . as i predicted, if you bet the over

    so . . . since i think i have tried everything you and the previous tech have suggested . . . i assume we are out of options and can blame godaddy . . .as i originally thought it may be, as i (and many others) have had issues with their hosting for years now and are not fans

    let me know what you think – as always, thanks for the support/sorry i was not timely replying, but it is working for my client, just not producing the nice monthly reports (like i think it once did)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @larclericalpluscom, thank-you for the update and I fully appreciate your entertaining style of writing to explain the process you’ve been through, even if it wasn’t so entertaining for yourself!

    You should be able to view the cron dates as described in my original response by simply being an administrative user of WordPress on your client’s website so could bypass the hosting control panel altogether if you’re not authorised to use that. If the job for “wordfence_email_activity_report” is dated in the past and will not update, this value could potentially be altered in the database, or more easily by using a WordPress plugin that manages cron jobs. Once the new date/time is reached, the email should be sent as expected and the cron date should be updated to another future date.

    However, if the cause of the cron not updating is a problem with the actions the host itself will allow, you may be left with no choice but to seek an alternative provider.

    Whilst I understand only some emails are not being received, here are some general tips we sometimes give out that could help:

    If you are not receiving emails, the unlock emails actually come from your website and not our servers. If you aren’t getting emails then you might want to check:

    • The emails (they come from wordpress@yoursitename.com) are getting sent to your junk mail folder by your email client or provider. Make sure and whitelist or add your website to the list of safe domains so you get emails consistently.
    • Your web server is having a problem with the email software on it. This isn’t like regular emails you send and receive, but rather server alert messages. Usually, a restart of postfix or sendmail (whichever is installed) can fix it. Your hosting provider may need to help with this.
    • Your hosting provider has disabled SMTP from the server for some reason like preventing the server from being used to spam people.
    • You have a third party plugin for sending emails with another service, like Gmail, which isn’t working. Reaching out to the plugin author for support can help.

    Please let me know how you get on.

    Thanks again,

    Peter.

    Thread Starter lar

    (@larclericalpluscom)

    Peter –

    look at this, a reply the same day from me – it’s gonna snow

    thanks for the feedback on my writing – I try to have some fun in life- never hurts . . . except for those folks who think they are too important for any fun in their life

    I have to say thank you for the knowledge that there is plugin to read/manage cron jobs (of course there is, silly!) . . . I have been working with WordPress for 11 years now, and never knew this, but then again, I have never had a reason to know this either

    so I installed the leading plugin for this functionality . . . and many of the wordfence cron jobs had the default start date for unix or whatever this OS is of 12/31/69 . . . so I tried to rerun them and deleted the old entry for them

    what I assume is easiest for you and me is to share a screen shot of what i see
    for a listing of all the wordfence cron jobs see
    http://totalenergyservice.com/wp-content/uploads/2021/02/2021-02-15-10_18_20-Cron-Events-%E2%80%B9-%E2%80%94-WordPress-%E2%80%94-Mozilla-Firefox.jpg
    for a listing of the errors on the top of the plugin cron listing page see
    http://totalenergyservice.com/wp-content/uploads/2021/02/2021-02-15-10_31_58-Cron-Events-%E2%80%B9-%E2%80%94-WordPress-%E2%80%94-Mozilla-Firefox.jpg

    I assume these are being blocked by my favorite host godaddy, but I will leave it up to you to decipher and tell me what you think

    as always, thanks for you accurate, complete and timely replies (but there is no rush on this one if you are busy)

    have a wonderful day

    Plugin Support wfpeter

    (@wfpeter)

    Hi @larclericalpluscom,

    I’ve had a word with some of the wider team and we may be able to assist. We have seen 429 errors with GoDaddy before but there might not be a way to kick the cron jobs in the normal way if the host is blocking them. You might be able to use define('ALTERNATE_WP_CRON', true);, even if you only use it temporarily.

    This makes cron run during a normal WordPress request, rather than firing a separate request to wp-cron.php. It makes query strings when a cron job is ready to run on some visitor requests, and may slow down some page views, but this may be a better solution than cron jobs not running at all.

    Thanks,

    Peter.

    Thread Starter lar

    (@larclericalpluscom)

    hey Peter, thanks for the team effort!

    i do appreciate it and will try to do all i can to see if your above/last reply suggestion will work

    sorry to see there are 428 other folks who are not happy with godaddy!

    so, full disclosure, i am not a cron guy like you, so i have captured and will share everything i did

    first i did an add . . . note, the add only worked when i did the entire command and argument in the hook name – if i did an add with the “true” as an argument, it failed to add

    http://totalenergyservice.com/set-up-2021-02-18-15_39_06-cron-events-wordpress-mozilla-firefox/

    so this is what it looked like after i did the add

    http://totalenergyservice.com/after-add-2021-02-18-15_40_13-cron-events-wordpress-mozilla-firefox/

    i opened the site and there appeared to be no change to the cron event after a refresh (i assume you meant that above, that it would fire upon open of the site)

    then i clicked the run now option popup when you hover over the listing, and i got this

    http://totalenergyservice.com/after-run-now-2021-02-18-15_40_50-cron-events-wordpress-mozilla-firefox/

    as you can see, it shows the default OS first date time stamp, and did not run (?)

    i then deleted the two entries as i am sure that adding/invoking cron hooks goes against godaddy policy and i don’t want to screw my client and have them frozen/not working by mr go daddy himself (danica i think is gone now)

    what did i do wrong, or does is just not work?

    and just in case, i am using “WP Crontrol enables you to view and control what’s happening in the WP-Cron system.”

    hope this helps – let me know what you/your team thinks

    Thread Starter lar

    (@larclericalpluscom)

    hey bad news – i have to stop with this ‘testing’ to get your reports to work

    my client sent me this:

    Howdy!

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, WP Crontrol.

    First, visit your website (http://totalenergyservice.com/) and check for any visible issues. Next, visit the page where the error was caught (http://totalenergyservice.com/wp-admin/tools.php?page=crontrol_admin_manage_page) and check for any visible issues.

    Please contact your host for assistance with investigating this issue further.

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

    http://xxxxxxx.com/wp-login.php?action=enter_recovery_mode&rm_token=xxxxx&rm_key=xxxxxxx

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.6.1
    Current theme: Typal.makewp005 (version 1.3.8)
    Current plugin: WP Crontrol (version 1.9.1)
    PHP version 7.2.25

    ————————————

    granted, it’s ‘only’ wordpress that caught/flagged the error – but i/we have no idea if it also prints/shows on a godaddy master console

    so as i said above, i can not/will not put my client’s site at jeopardy with godaddy, thus i have deactivated and uninstalled the plugin (along with compressing the DB to remove any tables)

    i hope you understand . . . net net, it’s still working, however not producing the reports . . . my client was fine this . . . i was the one who wanted to find out why (i have been working IT for 41 years now)

    many many thanks for all your help – hopefully you can find someone else who has the nads to complete this testing

    be safe, be well, be smart!

    Plugin Support wfpeter

    (@wfpeter)

    Hi @larclericalpluscom,

    Thank you for all the input so far and sorry to see you can’t continue with the investigation into this. Hopefully you will be able to find a solution in the future, although switching hosts may be the only option if they are unable to allow crons under any circumstances on shared hosting.

    Keep us posted if you find a way around this as that information would be very valuable for other customers in a similar situation.

    Thanks,

    Peter.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘email summary report not being produced or sent to me – part 3’ is closed to new replies.