Support » Plugin: Yoast SEO » Email Share Button – Not Adding Description & Image to shared url

  • Hi,

    When coping and pasting a web page url into email, usually a description& image are automatically added under the link in the email’s body.

    When testing an email share button on my site, I realized that the url is shared in the email’s body – but description & image are NOT added.

    Can you please help me figure out how to fix this and have the description & image of the shared page added under the url?

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support amboutwe

    (@amboutwe)

    As much as we’d love to help, Yoast SEO does not create the share button output and, therefore, this support forum is not the best place to request assistance. Please contact the support team or developer of the plugin that creates the share button.

    • This reply was modified 4 years, 11 months ago by amboutwe.
    Thread Starter nichelead

    (@nichelead)

    Ok, thanks.
    I thought that getting the description & image when sharing a url through email is similar to the open graph etc.
    I still have no idea how the link that is shared through email suppose to get the description & image info from the shared web page – whether it is through a button, or manually copying & pasting the link in the email body.

    When I copy a url from your site and paste it into an email it populates the description & image.
    When I do the same with url from my site, it doesn’t…

    Thread Starter nichelead

    (@nichelead)

    Hi,

    I found out that Yahoo Link Preview actually uses open graph to pull the description & image of a link that is shared in an email. (here is the topic https://answers.yahoo.com/question/index?qid=20140616062702AAtrxpy).

    From some reason, it doesn’t pull the image from my web pages with the link (the description is pulled). Any idea what may cause it?

    You can try copy and paste url from my site and see…
    https://SuccessGoose.com

    Any help will be greatly appreciated, Thanks!

    Plugin Support amboutwe

    (@amboutwe)

    The meta tag is output correctly. The image works. I don’t see any blocks in your robots.txt file. Facebook debugger shows the image correctly.

    Unfortunately, there doesn’t seem to be an obvious reason why Yahoo Link Preview would not display the image. I’d recommend reaching out to Yahoo support for advice.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Email Share Button – Not Adding Description & Image to shared url’ is closed to new replies.