Support » Plugin: SendGrid » Email sent from the Subscription Widget goes to a redirect loop In Pantheon

  • Email confirmation sent from the Subscription Widget goes to a redirect loop In Pantheon hosting.

    Test setup:

    WP 4.9.8
    Nginx 1.8.1
    PHP 7.2.10
    Sendgrid plugin 1.11.8
    TwentySeventeen 1.7
    No other plugin installed aside from Pantheon’s Must-Use
    Hosted in Pantheon

    Working on another test setup using same setup, only difference is it is running in Apache server and it works fine.

    Consulted with Pantheon and it was due to double underscore parameter (__sg_api) generated in the link sent by that plugin as that kind of format affects caching performance in the platform: https://pantheon.io/docs/pantheon_stripped/#resolution.

    Is there a way to customize the parameter __sg_api via a builtin hook without modifying the code plugin itself?

    • This topic was modified 1 year, 1 month ago by Carl Alberto.
Viewing 1 replies (of 1 total)
  • So far, the only workaround is manually changing the __sg_api to any variable like sg_api without any double underscore as prefix in these file/lines:

    sendgrid-email-delivery-simplified/lib/class-sendgrid-mc-optin.php:25:    $vars[] = '__sg_api';
    sendgrid-email-delivery-simplified/lib/class-sendgrid-mc-optin.php:40:    if( isset( $wp->query_vars['__sg_api'] ) )
    sendgrid-email-delivery-simplified/lib/class-sendgrid-mc-optin.php:146:    $confirmation_link = site_url() . '/?__sg_api=1&token=' . $token;
    • This reply was modified 1 year, 1 month ago by Carl Alberto.
    • This reply was modified 1 year, 1 month ago by Carl Alberto.
Viewing 1 replies (of 1 total)
  • The topic ‘Email sent from the Subscription Widget goes to a redirect loop In Pantheon’ is closed to new replies.