WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] email registration & retrieve password not being sent

[Resolved] email registration & retrieve password not being sent

  • I have the latest install 1.5.2 and I’m currently testing user registration and password retrieval. As admin, I receive an email advising that a new user has signed up. This is good!

    As a test user when I register using a valid email address I received NO CONFORMATION email nor do I recieve a email advising new password generation. This is bad!

    When I requested a new password (retrieve) I received an email with a link format so I could change the password. This is good!

    I suppose two out of three isn’t so terrible odds.

    However, it would be nice to receive an email in the first instance to confirm (as a user) that I have registered to this blog and offer me a dummy password which I can change once I log in.

    I know, I know, WordPress generates this automatically. But it’s NOT WORKING. I’ve read the FAQ and numerous other threads but there seems to be a disturbing trend here. Codex is telling me that I don’t have to do anything, that wordpress mail will generate all necessary emails.

    Obviously this isn’t quite true. Can someone advise me how to fix this problem, please.

    Thanks in advance

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator James Huff

    @macmanx

    Thanks macmanx for your help. I really appreciated it.

    Unfortunately, like I said in my original email, I have read the Codex files and numerous threads on this issue.

    Quote from the Codex files…

    “WordPress uses the standard php mail function, which uses sendmail. No account information is needed. This is not generally a problem if you are using a hosting service, Unquote:

    I have a hosting provider. This simple function does not work. Given the threads on this issue, I can only assume one of two things:

    this mail_function STILL does not work, and people have moved onto other important blogging/design issues without gaining resolution

    OR

    the resolution was found, but not updated appropriately in the CODEX files.

    I am asking for help here, from some knowledgeable individual who has fixed this problem.

    Thanking the gurus in advance

    Moderator James Huff

    @macmanx

    Have you contacted your hosting provider to ask if they have any sendmail or postfix restrictions?

    Again, thanks macmanx for your help.

    I’ll email them now to see if this is so. I’ll get back if there’s no issue their end.

    Happy Christmas!

    It appears that this password generation email to user does not work on my IP address? even though I have used another valid email address not associated with the install.

    I had a friend register today and she received the password email on her computer.

    I suppose I answered my own question. It works, but just not on my laptop.

    Stranger things have happened…

    Moderator James Huff

    @macmanx

    Check your email client’s spam filter. It may be blocking WP’s emails.

    Hi how can i add avatarS?

    Moderator James Huff

    @macmanx

    Ben, use the search field in the top-left. If you don’t find any useful information via that, just create a new thread.

    Sorry macmanx for taking so long to reply…

    I did as you suggested and checked my own email filters. You’re completely right, of course. I added my own dot.com address and bingo – I get the user registration password sent to my email box.

    Thanks so much for your helpful advice.
    It’s worth my weight in gold 🙂

    Kate

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] email registration & retrieve password not being sent’ is closed to new replies.
Skip to toolbar