Support » Plugin: Formidable Forms - Form Builder for WordPress » Email received but posted form data is all one one line

  • Hi,

    Great plugin – just the job. Only problem I have is that when form is submitted the email is received fine but the contents (labels & posted values) are displayed on one line.

    eg. Contact Us form has been submitted on [blog name]. First Name: Fred Surname: Bloggs Email:

    My email client is Gmail. When I view “Show Original” in gmail i can see that the headers include:

    Content-Type: text/html; charset=”UTF-8″

    and in the source of the email each label and posted value is on a new line.
    Is it a settings in WordPress? or my email client?

    any help much appreciated.


Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,

    I have had the same issue in the past. Unfortunately there is a little quirk in WP (not necessarily Formidable). You need to create the response in “form notification options” using appropriate html tags (in your case you need paragraph or line break tages). Once you have it looking the way you like it, I would copy the html to a notepad file and save it.

    For some reason, when you close and then reopen the form notification options, the p tags (and other html) dissappear. Very frustrating but it’s not unique to Formidable. Save the text file and if you have to edit in the future, just cut and paste.

    Hope this helps.

    The problem isn’t with the display of the form, its the contents of the Email that gets sent once the form has been submitted.

    I posted this also on the developers forum – and actually I think I’ve found where the problem is and how to rectify it, BUT its hardcoded and it would be wiped with a future update.

    I’ve asked how best to get around this but i’m still awaiting a reply.

    Right… it’s the same problem… believe me I have been through this.

    I assume you have “Auto responder” checked in “Form notification options”? If so, the same html problem will persist. Specifically in your case, it wipes out any < P> tags. Try an experiment if you don’t believe me; add some paragraph tags, test your form to see that they work, leave the options page, and then return to it… your tags will be gone and all the emails will return results “all on one line”. You need to use the Ronco slogan: “Set it, and forget it!” or do as I mentioned above, copy your mark up into a notepad ++ file (or similar).

    The reason I am answering this: Often times questions go unanswered and there have been several people who have helped me in the past (not the least of which is Stephanie Wells from Strategy11) so I am trying to give back.

    Good luck,

    [sig moderated as per the Forum Rules]

    >”[sig moderated as per the Forum Rules]”

    Well, I didn’t mean for it to be a sig file. I was simply saying that I am a very happy user of Formidable Pro and there are examples of forms I created at


    I assume you have “Auto responder” checked in “Form notification options”?

    Actually I don’t. The only thing I have in “Form notification options” is Email Form Responses to: [email address].

    I am running the Basic free edition – I guess thats why I can’t see what your trying to explain. Must be a Pro edition feature.

    Hi Khidhaboy,

    You are correct, I do have the pro version but I think the function you are looking for exists within the free version. If not, sorry to have wasted your time.

    I am sure Steph will get you pointed in the right direction.

    If you want to send a screen shot I can try and help further or send you a screenshot of what I am doing… mikemcd at ecrt dot com

    Good luck.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Email received but posted form data is all one one line’ is closed to new replies.