Support » Plugin: WC Vendors Marketplace - The WooCommerce Multivendor Marketplace Solution » Email Problems: Vendor notify application (both customer and admin)

  • Resolved ouija

    (@ouija)


    Hi there,

    Been having email issues with the (free) plugin since the new version was released.

    Running latest update and still having issues with the “Vendor notify application” being sent twice and the “Admin notify vendor application” not being sent at all.

    Any ideas what may be causing this? I’m using the SMTP plugin for WordPress and I can see in the log that this is indeed the case.

    Let me know if you have any ideas or suggestions. I’ve tried disabling the “Vendor notify application” to see if maybe something else was triggering it to send twice, but it won’t send at all (as it should) and sends twice when enabled.

    Is the pro version working properly? I may upgrade to that if this continues with the free version (that’s your ploy, isn’t it? :p)

    Thanks!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Jamie

    (@digitalchild)

    Hello,

    There are 2 sets of emails, the legacy emails and the new emails.

    Do you have “Vendor Application” enabled? Legacy notify email.

    Are your vendors auto approved or manually (everyone is pending_vendor) first. What emails do you have enabled? Can you send a screenshot?

    Regarding pro

    The pro version is working properly but it doesn’t have any emails in it. Pro works on top of free, so it won’t solve your issue here 🙂

    Pro is more for providing a nice clean streamlined interface for your vendors including complete product management on the front end. Vendors do not access wp-admin with Pro. They also have access to a shipping system and other features not available in free.

    Here’s a comparison: https://www.wcvendors.com/home/comparison/

    cheers,

    Jamie.

    Thread Starter ouija

    (@ouija)

    No, I originally had the “Vendor Application” enabled with a custom template override, but disabled it after upgrading (and see the ‘degraded’ notice for it) and enabled the “Vendor notify application” and the “Admin notify vendor application” instead.

    Vendors are being approved manually.

    Looking in the Postman SMTP log, the “Vendor notify application” is indeed being sent twice, while the other isn’t being sent at all.

    Thanks for you assistance with this.

    Plugin Author Jamie

    (@digitalchild)

    Hello,

    Ok. Something must be triggering the email twice. The question is what? Do you have the ability to setup a staging environment for testing? I’m wondering if something in your configuration is causing the issue as I’m unable to replicate this issue for the double email send.

    Regarding the admin notify email, there is a known issue with this that we are working on.

    cheers,

    Jamie.

    one email is triggered from the my account page when you click on Apply to be a vendor. that takes you to the page to enter your information. The 2nd one is triggered by clicking on Apply to be a vendor on that page

    Also, the first one goes out along with the Thanks for creating an account email

    Plugin Author Jamie

    (@digitalchild)

    Hello @madeinaustralia

    Please do not use these forums for premium support. Please submit a ticket on our website for anything related to pro.

    We are forbidden from providing support for our pro products here.

    cheers,

    Jamie.

    Thread Starter ouija

    (@ouija)

    Sorry for the long delay, been busy in development and gave up on this for some time.

    Testing today, and I’ve found that the email notification system in WC-Vendors (free) is still wonky.

    The last update seems to have resolved the Admin notify vendor application email from not being sent (which is great), however, now the “deny vendor” notifications are messed up and they are sending out the “Admin notify vendor application” and “Notify Vendor Application” emails, instead of the single “Vendor Notify Denied” email (and Postman SMTP confirms this).

    Grrr…

    Thread Starter ouija

    (@ouija)

    Yeah, I don’t understand what is causing this other than the plugin itself, I’ve checked everything I can (no actions or hooks that could be causing it) and the email issue seems random; Yesterday I was getting vendor denied emails, and today it’s sending the application email instead. And it sends the vendor application and admin vendor application emails twice still.

    The original “Vendor Application” email notification seems to work without issues — no duplicate emails, and correct emails sent based on application/approval/denial.

    Hopefully it won’t be removed until these new “Admin Notify Vendor Application / Vendor Notify Application / Vendor Notify Approved / Vendor Notify Denied” emails work properly!

    I’ll maybe try re-installing the plugin to ensure it isn’t some strange file issue or something causing this, but I have no idea at this point.

    • This reply was modified 3 years, 9 months ago by ouija.

    Yesterday i got the vendor application received email triggered by the apply to be a vendor/login page. But received no notification once they had filled in their details. I couldn’t work out why i had no option appearing to approve the vendor. It finally appeared. Must have been after they completed their details. Weird.

    But i am happy with how it is working overall

    Thread Starter ouija

    (@ouija)

    It’s odd; I’ve had issues with the new Vendor Approved/Denied/Application email notifications since they were introduced earlier this year; The old “Vendor Application” notification is working well and doesn’t seem to have any of the aforementioned issues so I’ll utilize it for now as I am going live with this client site in a production environment on Monday and cannot afford to have these notifications failing or being sent twice.

    As requested, here’s the screenshot of the enabled notifications when I am having issues with duplicate emails and incorrect emails being sent: https://i.imgur.com/RukP1Vf.jpg

    • This reply was modified 3 years, 9 months ago by ouija.
    • This reply was modified 3 years, 9 months ago by ouija.
    Plugin Author Jamie

    (@digitalchild)

    Hello,

    We have had a few reports and are trying to replicate the issue however emails have always been an issue with WooCommerce in general. When it comes to some hosting emails fire while others it doesn’t. We are unable to replicate these issues and emails are all firing in our testing environments atm. We are doing what we can to replicate and resolve this issue for our next release.

    cheers,

    Jamie.

    Thread Starter ouija

    (@ouija)

    I cannot give you access to the staging server for this client site unfortunately as it is behind a corporate VPN, but I will eventually try and isolate the cause of the issue by disabling all plugins on the site and seeing if it is caused by a possible conflict there.

    It’s working for now via the depreciated Vendor Application method, so I’m good with that, but will try and find out what is causing this issue when I have time to debug and will post my findings back on this forum.

    Thank you!

    Plugin Author Jamie

    (@digitalchild)

    Hi @ouija

    I use WP Mail log plugin to debug my email issues on all my sites. All the new vendor notify emails are using the same triggers as the old ones, however the trigger itself may be having an issue. If you want to dig into it further at some point. You can report your findings on our GitHub https://github.com/wcvendors/wcvendors

    I won’t be removing the deprecated emails any time soon as we have a lot of users with custom email templates for these.

    cheers,

    Jamie.

    Hi @jamie

    I would just like to find out if you guys have managed to figure out why the email issue is occurring?

    Everything is working 100% but I am receiving 2x emails to new vendors, and 2x admin notification mails.

    I have stock standard WP installation, no SMTP email plugins etc.

    Any help would be great thanks!

    • This reply was modified 3 years, 6 months ago by mikerookie11.
Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Email Problems: Vendor notify application (both customer and admin)’ is closed to new replies.