Support » Plugin: Revisionary » email notifications not working

  • Resolved hcaweb

    (@hcaweb)


    Hello!

    I went through the instructions @ https://publishpress.com/docs/emails-revisionary/ to figure out why the e-mail notifications aren’t working for me. E-mail log shows e-mails being sent out for other things, but for some reason, Revisionary isn’t sending out any e-mails, even with the settings set to “Always.”

    I am using the latest version of WordPress as well as well as the Revisionary plugin.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Kevin Behrens

    (@kevinb)

    Thanks for using Revisionary, and for taking the time to report this issue.

    Can you confirm that your updates are changes to published posts, not submission of new posts? If so, here are some additional questions:

    First, take a look in your junk/spam box. Next, can you confirm delivery of other email notifications from the website, such as new user notifications?

    Another factor is the WordPress role of your moderators. Are they actually in the “Administrator” or “Editor” role, or a similar role with some other name? By default, Revisionary will not send notifications to editors who have a custom role. If this is your situation, I can provide a snippet of custom code to adjust the configuration.

    Finally, please let me know if you are running any other permissions-related plugins.

    Hi Kevin,

    Yep, I did both new and updated posts and pages, checked the junk/spam box as well as the “Email Log” plugin and didn’t see anything. When I changed the Settings > General Settings > Email Address, I got update notification by email (as well as it showing up in “Email Log”)

    Currently, with the exception of the test user account that has the “Revisor” role, the other accounts show up as “Administrator” in the Users section. None of them have receieved emails too.

    The “Groups” plugin was installed by our system administrator, but I’ve never used it nor has it been configured, etc. I’ve deactivated that as well and tested it again and no e-mail was sent out..

    Thanks!

    Plugin Author Kevin Behrens

    (@kevinb)

    @hcaweb, can you email use at help@publishpress.com so I can troubleshoot your installation further?

    Plugin Author Kevin Behrens

    (@kevinb)

    @hcaweb, I released Revisionary updates today which should restore Pending Revision notifications for two major use cases:

    • Multisite installations (whether network-activated or not)
    • Any installation using the default Revisionary email setting to notify Administrators and Editors “By default”
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.