• Resolved Cliff Seal

    (@cliffseal)



    After a recent update (it seems), I now receive email notifications for core integrity notifications and available updates—neither of which I received previously. I’m set up on a massive number of sites, so my inbox is now constantly filled with Sucuri emails. Email sending was working fine before—so that’s not the cause—and my settings haven’t changed on any of these sites.

    Was there a recent change that would have triggered this? And, is there any way I can disable it with a constant or hook? It would be extremely time-consuming to get into each individual site just to make this change when things were set up just fine before. I do want to continue to receive email notifications, as I want to know about brute-force attacks, etc..

    Thanks!

    https://wordpress.org/plugins/sucuri-scanner/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author yorman

    (@yorman)

    Version 1.8.1 [1][2] fixed this issue.

    The alerts about inconsistencies in the core integrity checks are not new, they have been available for more than a year. Version 1.7.18 changed the default value for the option “Receive email alerts for core integrity checks” because we wanted people to be aware that the plugin was finding inconsistencies in their projects. Some people complained about these emails so we decided to revert that default value to “disabled” in version 1.8.1; people that have not updated can still go to the “Alert Events” panel located in the plugin’ settings page and deactivate that option manually.

    [1] https://downloads.wordpress.org/plugin/sucuri-scanner.1.8.1.zip
    [2] https://github.com/cixtor/sucuri-wordpress-plugin/commit/a747e85

    Thanks! Does this also apply to “available updates”? I seem to still be getting those even after running the latest version of the Sucuri plugin.

    Plugin Author yorman

    (@yorman)

    The option to send email alerts for available updates will be kept “enabled” by default, I don’t see the point on keeping that option disabled for new installations of the plugin. If you want you can disable those alerts from the same page mentioned in my previous comment.

    Ok, I totally understand, but what I’m saying is it was turned on for existing installations. I’m getting flooded with emails from tons of sites that had Sucuri’s alert settings all perfectly set up for email notifications previously, but now are sending these available update messages.

    Plugin Author yorman

    (@yorman)

    I understand your concern about the alerts for available alerts from websites with previous installations of the plugin, I will revert that option too, but as I understand the websites that you are managing are auto-updating, so even if I send the fix now to the repository those websites will not pick the fix because they are only updating the code available in the WordPress repository. I will talk with my project manager to see if we can release a new version of the plugin with these fixes this week.

    Got it. Even if you tell me what to change in the code (or show me a patch/commit), that would work for me as well.

    Plugin Author yorman

    (@yorman)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Email Notification Overload’ is closed to new replies.