Support » Plugin: WooCommerce » Email notification for new order not being sent

  • Resolved objex

    (@objex)


    The New Order notification email doesn’t send when an order is placed.

    It DOES, however, properly send an email when a Order Actions-> Resend new order notification is done in the admin section.

    It also properly sends an email notification when I chance an order’s status to Complete.

    It seems whatever hook for the New order isn’t catching and triggering an email to the admins, what steps can I take to make sure the New Order notification email is sent?

    Thanks all!

    (woocommerce version 3.2.6)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @objex,

    Cross testing for you using the latest version of WooCommerce to gain a set of comparison results the new order emails of the WooCommerce plugin worked correctly isolating this to only your particular install.

    To quickly test emails you can use a plugin like this below to log all outgoing emails from WordPress and view those from admin, this way you can purchase test orders and see what emails were sent out, to whom they were sent and the content of those emails.

    https://wordpress.org/plugins/wp-mail-logging/

    If the email is logged in this plugin it was sent out correct and is not being received which is not something we could control from WooCommerce.

    If that is the case possibly sending our all WordPress emails from SMTP would resolve this for you instead of using the default WordPress mailer functionality.

    http://www.wpbeginner.com/wp-tutorials/how-to-use-smtp-server-to-send-wordpress-emails/

    Sometimes emails sent directly via a web server can be marked as junk/spam or be blacklisted by your email provider meaning you would most likely not receive those.

    I hope this helps you to narrow the cause of this down.

    Hi thanks for the quick reply, and yes, that was helpful.

    I’ve set up the logger and it shows the initial emails as having a ! symbol in the error column when I create a new order.

    However, when I do a Order Actions-> Resend, it delivers the email and shows up in the logs without error.

    In WooCommerce, are there different settings between sending the initial new order notification and the resend?

    e.g. if it works for the Resend, should it not work for the initial order as well?

    and is there more info I can get about the error in the logs? it just shows up as an “!”, without any more description

    Plugin Support Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    In WooCommerce, are there different settings between sending the initial new order notification and the resend?

    No.

    e.g. if it works for the Resend, should it not work for the initial order as well?

    That is a reasonable expectation, yes, however, there would be different pieces of software interacting with the process in the two different cases. One thing is that theme files wouldn’t be loaded when re-sending the email from the admin as opposed to going through the checkout process. I’m not familiar with what the exclamation points might mean in the email logger, but I would suspect that a PHP fatal error has occurred when trying to send the email. I would suggest that you have a look at the PHP error logs for clues as to what might be causing that.

    You can also do conflict troubleshooting. You can do that by temporarily switching to a default WordPress theme such as WordPress Twenty Seventeen Theme (https://wordpress.org/themes/twentyseventeen/) or Storefront (https://wordpress.org/themes/storefront/) and disable all plugins except for WooCommerce. If that resolves the issue, then re-enable features one-by-one until you find the one that’s causing the conflict.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Email notification for new order not being sent’ is closed to new replies.