Support » Plugins » [Plugin: Contact form 7] Email not sending to some email addresses

  • I have tested the Contact Form 7 plugin, and it works like a charm, for the most part. If I am sending to an address *outside* my domain, the mail sends properly, but if I am sending an email to an address @mydomain.com, the mail never sends.

    Has anyone else had this problem and figured it out? I recall seeing one post in another (fairly long) thread that mentions this, but nobody responded to that particular post.

    Thanks.

Viewing 1 replies (of 1 total)
  • I am having the same issue with a new WordPress MU installation. If I put an address in the TO field of the Contact Form 7 admin UI, when I submit the form the email comes through with no problem.

    However, if I put in an address that has a domain that hosted within the hosting environment the site is set up in (Rackspace and Rackspace Mail) the email don’t come through.

    Similarly, my attempt to use SMTP authentication errored on the TO address, which had a domain that’s within that environment (although I did not realize that when we were testing SMTP auth).

    I’m currently working this issue with my hosting vendor tech support. Assuming we figure that out I’ll post what I learn here.

    Otherwise, if anyone else out there has any insight into this issue that would be appreciated!

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Contact form 7] Email not sending to some email addresses’ is closed to new replies.