Support » Plugin: Fast Secure Contact Form » Email not being delivered – Solved

  • Resolved tgschaef

    (@tgschaef)


    I wanted to share my experience as I have seen similar posts of problems and struggling with this for over a month. If you are having trouble getting mail to send out, turn off “Enable sender information in email footer.” found in Advanced->Advanced Email Settings. (Along with the standard recommendations of reply-to and return-path settings)

    Something… Somewhere changed about a month ago and any email leaving my host (Bluehost) with that kind of information in the footer gets dropped. Bluehost insists it leaves their server but somewhere between them and every email I tried would not receive it. Except what went into their email inbox. Since every email address at this domain gets forwarded to other email addresses not on the domain, this was not immediately obvious.

    I zeroed in on the problem after a combination of knowing that confirmation and test emails from FS Contact Form went out fine and then a similar install on a different host would get the email out to everybody but what went through the initial host. Then pondering what might be different that might trigger a drop.

    I suspect everyone that went to CF7 found success as it doesn’t have this information at the bottom by default. When I tried CF7 I foolishly tried to make it look as much as possible to my original email and coded that into the message. So it still got dropped.

    I hope this helps someone.

    https://wordpress.org/plugins/si-contact-form/

Viewing 10 replies - 1 through 10 (of 10 total)
  • This is good advice and should be added as a consideration in the Troubleshooting docs.

    I’ve been successfully using this plugin for years on Bluehost, but a recent install has been a nightmare. I believe Bluehost recently made some policy or server changes regarding email delivery, and it complicates matters.

    I added that suggestion to the help page for email not sending

    Problem: I do not receive email, email does not send, or always goes to the Spam folder.

    In the nick of time, thank you!
    Confirmation emails were sending fine, then not — just when I happened to see this at the top of the forum list. Saved much grief, thank you!

    Curious what new thing triggered the problem as including sender information WAS working. Suspect a plugin firewall that did not correctly self-configure. Will test sender information again when working during a lax traffic period (not on Bluehost).

    Nice!

    Yes, that was my experience. Everything was working, then it wasn’t except a rare message every now and then.

    I use Bluehost and Hostgator. Form emails with sender info from Bluehost were being dropped but not Hostgator. My guess is that some spam rule somewhere has a hair-trigger for email from Bluehost for whatever reason.

    Okay, able to use “Enable sender information in email footer” again. Believe problem was Wordfence firewall configuration.

    WF autoselected the setting “Apache +suPHP (recommended based on our tests)” which sounded good because they had tested it, right? After several other odd happenings, I thought to verify the WF selection with the host. Turns out the correct selection for us is “Apache + CGI/FastCGI”. Not 100% sure that was the only factor in the email delivery problem but all is working again. (Reported to WF.)

    The “disable sender information” temporary fix above was critical to get confirmation emails delivered until a solution showed up — thanks again! The sender information is only helpful in rare instances, anyway, like when deciding whether or not to accept somewhat-odd information provided on the form.

    Thanks so much! This fixed my problem with the plugin.

    @mperry8304, which was the fix for you, disabling sender information or Wordfence firewall configuration? Might help clarify source of problem. Thanks!

    @wilderbee, I followed @tgschaef‘s advice and did this:

    If you are having trouble getting mail to send out, turn off “Enable sender information in email footer.” found in Advanced->Advanced Email Settings.

    It worked like a charm!

    @tgschaef that is great find and thank you for sharing this invaluable information. It is strange though that some server configurations blocks the e-mails with this feature “Enable sender information in email footer.” enabled.

    Since the this is not an issue but a solution, can you mark this thread as resolved.

    Thank you

    @wilderbee At least the IP address is saved to Contact Form DB if you use that. The detailed sender info has never been useful to me, but is there a way to get the user agent, resolved IP, etc as well into CFDB? I will investigate if only to occasionally see who is a IE/Firefox/Linux user. ;-b

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Email not being delivered – Solved’ is closed to new replies.