Support » Plugin: Contact Form 7 » email is sending, but no notification on screen

  • ContactForm7 v4.6 with Flamingo…

    users submit a form, and the form gets successfully sent, received and documented in Flamingo.
    However, there is no notification to the user that the form was submitted successfully.

    Attempting to submit the form again results in an error displayed properly in an orange box…

    firebug shows an error when the first submit is pressed (and no notification gets displayed)
    ReferenceError: ga is not defined

    The error is not repeated when the button is pressed again (and that successfully displays an error notification)

    as a side note, I also get the following in the firebug console:
    Use of getPreventDefault() is deprecated. Use defaultPrevented instead.
    Error: ReCAPTCHA placeholder element must be empty

    https://www.chelmsforddogassociation.org/submit-report/

    • This topic was modified 4 years, 11 months ago by kindred.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    What do you have in the Additional Settings tab?

    Thread Starter kindred

    (@kindred)

    I have

    on_sent_ok: “ga(‘send’, ‘event’, ‘Contact Us Form’, ‘submit’);”
    flamingo_email: “[your-email]”
    flamingo_name: “[your-name]”
    flamingo_subject: “** Issue reported on CDA Website by [your-name]”

    the first is what comes, predefined with the basic, default form – so I didn;t touch that
    the other three were requested to be added by Flamingo

    On reviewing, it seems that it should have
    on_sent_ok: “alert(‘sent ok’);”

    — but how do I trigger the ajax message, as defined in the messages section
    e.g. >> Sender’s message was sent successfully

    One would assume that gets automatically loaded on a success, just like the others get loaded on a failure

    @kindred – Did you get this resolved?

    I have just encountered the same problem. The form submits on the front end of the site, email is triggered to recipient, but no confirmation message is displayed on the front end.

    Let me know if you fixed it!

    Thanks!

    Thread Starter kindred

    (@kindred)

    Well, yes and no…

    by switching the on_sent_ok line from the default ga value to
    on_sent_ok: “alert(‘Thank you. Your message will be reviewed.’);”
    instead, it now triggers a javascript alert

    but it still does not trigger the ajax “green box” that it indicates should be displayed…
    (errors do still trigger the yellow and red boxes, as expected)

    Oh well – thanks for getting back to me.

    In the end I’ve rolled back to the previous version of the plugin and it has resolved it for now. That’s Version 4.5.

    Hope that helps.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘email is sending, but no notification on screen’ is closed to new replies.