Support » Plugin: Drag and Drop Multiple File Upload - Contact Form 7 » Email is not sent after upload. “Something went wrong while sending …”

  • Resolved itsebigaming


    Hey everyone,

    I downloaded and integrated the plugin today. The upload works fine, the files are also stored on the server. However, the error described here comes when I want to submit the form.

    Interestingly, the error does not appear when I submit the form without uploading. Therefore, I assume that the error is in the sending of the email after the upload.

    Unfortunately, the “Send as link” function does not remedy this.
    Otherwise, sending e-mails works flawlessly.

    Unfortunately, my installation is not publicly available, so I can’t give you access.

    Maybe you can still help me?!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter itsebigaming


    So I can send attachments via the upload tool from CF 7. Only when I use the upload window from the plugin, the files are uploaded but the email cannot be sent. It comes directly the error, there was an error and you should try again later.

    So it seems to be some error when sending with the plugin, because the normal upload function works.

    The emails from the CF 7 Upload Tool also arrive with the attachment without any problems. So there seems to be no issue with an upload limit.

    Is there a log function somewhere? Then I could give more details.

    Best regards,

    Plugin Author Glen Mongaya


    Thanks @itsebigaming for creating a new topic.

    Can you add these code on your wp-config.php?

    define( ‘WP_DEBUG’, true );
    define( ‘WP_DEBUG_LOG’, true );

    After that, test the form to see if there’s any error.log or debug.log file on your server.

    Also, I cannot identify the issue without checking the site, can you create a temporary page link where I can test?

    Please also share a screenshot of your browser console error?

    Plugin Author Glen Mongaya


    Other thing, a screenshot of you contact form 7 mail 1 & 2 settings.

    Thread Starter itsebigaming


    Hey @glenwpcoder,

    so, there seems to be no error in the console.

    I have enabled debugging, but no errors are displayed.

    The URL to test is:

    Which settings exactly are meant by “Other thing, a screenshot of you contact form 7 mail 1 & 2 settings.”?

    Here are two screenshot: &

    I have only activated the email 1. The e-mail 2 is deactivated.

    @glenwpcoder I am having similar problems since the last plugin update. The installation and provision of the code is easy to implement, but I simply don’t get a “Drag and Drop” box to pull images onto. I am left with a “Browse…” button for one upload, but when testing not even one file uploads. I have strained to look for any errors. There are no caches of any type installed.

    I added the following “define( ‘WPCF7_LOAD_JS’, true );” to the wpconfig.php file as suggested in one support ticket, but that throws an error:

    [30-Jun-2021 22:51:37 UTC] PHP Warning: Use of undefined constant ‘WPCF7_LOAD_JS’ – assumed ‘‘WPCF7_LOAD_JS’’ (this will throw an Error in a future version of PHP) in /home/fallcreektwp/public_html/wp-config.php on line 79

    Here is the form set up properly: Click on “Pantry Registration” under “I Need to Find…”

    Here is my current code that I have used before without a problem: [mfile upload-file-343 limit:24000000 filetypes:jpg|jpeg|png|bmp|tif|pdf|doc|docx|ppt|pptx|zip|rar max-file:8]

    This uploader used to work here with the same theme and version, same 1 GIG SSD dedicated server, same 32MB RAM size, same PHP 7.4 version, same upload limit, same current WordPress version, same plugins (although I deactivated them to test to no avail). The only difference is a clean new install of Drag and Drop Multiple File Upload on fallcreektwp that fails.

    The working form on surfaceking has been active and working for two previous versions. My client at surfaceking notified me just yesterday that the Drag and Drop Multiple File Upload is no longer submitting any files. That makes it fairly conclusive that it is a plugin issue, because it did work.

    I checked the error logs on both domains and nothing is recorded even though debug is active. Your plugin is simply not submitting attachments with the Contact Form 7 form submitted.

    Plugin Author Glen Mongaya


    @itsebigaming I cannot view the link need to login –

    @@inndesign, I tried to debug but I’m having a problem identify the issue, it seems like there’s no css/js loaded on the theme. Is there an option on the “themefusion” panel to disable/enable js minifies or something?

    Thread Starter itsebigaming


    Hey @glenwpcoder, the page should now be accessible.

    Best Regards

    @glenwpcoder I had a function.php code that limits Contact Form 7 script activity, which apparently is too aggressive for your loader. I have removed it:

    // Disable Contact Form 7 JS/CSS loading on every page speeding up page load time.
    add_filter( ‘wpcf7_load_js’, ‘__return_false’ );
    add_filter( ‘wpcf7_load_css’, ‘__return_false’ );

    Otherwise, as mentioned above, there is no caching or minification on fallcreektwp because it is a site being built.

    Nevertheless, both surfaceking and fallcreektwp do show the drop and drag, but no file or file type is ever delivered. The plugin simply doesn’t work anymore.

    Plugin Author Glen Mongaya


    @inndesign , can you check your Contact Form 7 – Mail Settings and make sure to add “[upload-file-343]” in Mail File attachment field? (see screenshot 1 )

    Also, make sure to uncheck “Send Attachment as links?” under contact -> Drag 7 Drop Upload – Settings (see screenshot 2 )

    screenshot 1 –
    screenshot 2 –

    @glenwpcoder, you are a wizard. The [upload-file-343] was indeed missing on both sites. The other website of course had a different numerical value. Works like a charm on both sites now! Thanks for your fantastic support!

    Thread Starter itsebigaming


    Hey @glenwpcoder ,

    do you already have an idea what it could be with me? Unfortunately, my error is still not fixed. It is apparently not comparable with the one from @inndesign .

    I would be very pleased about a feedback.

    Kind regards

    Plugin Author Glen Mongaya


    @itsebigaming , sorry for the late response.

    1. Can you check the allowed size on your mail server for the attachment?

    2. Can you enable browser console and send me a preview screenshot of the response.

    Just like this –

    To enable browser console – “use the keyboard shortcut Ctrl Shift J (on Windows) or Ctrl Option J (on Mac)”

    Also, I tried to upload a file but this error shows :


    • This reply was modified 1 year, 6 months ago by Glen Mongaya.
    Thread Starter itsebigaming


    Hey @glenwpcoder,

    thank you very much for your message.
    So I have here the following output from the console:

    By disabling spam protection, I was able to fix the error:
    add_filter(‘wpcf7_spam’, ‘__return_false’);

    Best Regards,


    Plugin Author Glen Mongaya


    Thanks @itsebigaming , I’m glad you already figured it out.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Email is not sent after upload. “Something went wrong while sending …”’ is closed to new replies.