Support » Plugin: WP Mail SMTP by WPForms » Email Delivery Error: Mailer: Gmail Host must be a string

  • Resolved apere125

    (@apere125)


    Configured WP Mail SMTP plugin to connect via Gmail API as described in these instructions.

    Authenticated the App OK but receive the below error message when configuration is saved. Unable to send test email, button is grayed out.
    Cannot find any posts with similar issues. Has anyone seen this before?

    Notes:
    *Google Gmail account has 2FA disabled and Less Secure Apps enabled.
    *No other SMTP configurations work to 3 other email providers…. Have been fighting this module for over 12 hours now…..

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v1.8.0 logged this error during the last time it tried to send an email:

    Mailer: Gmail
    Host must be a string

    Consider running an email test after fixing it.

    • This topic was modified 11 months, 2 weeks ago by apere125.
    • This topic was modified 11 months, 2 weeks ago by apere125.
Viewing 15 replies - 31 through 45 (of 45 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    WP Mail SMTP 1.8.1 has just been released.

    It should fix the issue with Gmail and Sendinblue mailers and “Host must be a string” error.

    The problem is SOLVED. Thanks so much!

    Thanks for the update, but I’m now getting another error message:

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v1.8.1 logged this error during the last time it tried to send an email:

    Mailer: Gmail
    {
    “error”: {
    “errors”: [
    {
    “domain”: “global”,
    “reason”: “required”,
    “message”: “Login Required”,
    “locationType”: “header”,
    “location”: “Authorization”
    }
    ],
    “code”: 401,
    “message”: “Login Required”
    }
    }

    Consider running an email test after fixing it.

    Should I reinstall the plugin and follow the setup steps once again?

    I don’t know if it’ normal but I also still have the “Allow plugin to send emails using your Google account” at the bottom of the page.

    • This reply was modified 11 months, 2 weeks ago by kukaracha.
    Plugin Author Slava Abakumov

    (@slaffik)

    @kukaracha This is a separate error, not related to the previous one.

    You will need to click “Allow..” one more time and allow to send. Perhaps something has been changed on the Google side (2FA, password, account settings etc).

    Hi Slava,

    Thanks again for your help and don’t worry, I simply reinstalled the plugin and everything works correctly now. Problem seems fixed.

    Cheers!

    @kmanrite – Yes, Gmail Oauth.

    @slaffik
    Thanks so much for your help!!! Working good now! Cheers!

    @slaffik Hi Slava, thanks for the info.
    Before upgrading do you still need those echo variables for your debugging?

    Just a note, I do not have shell access to my web host.

    Thank you for the quick fix!

    THANK YOU! Truly professional response!

    “Congrats, test email was sent successfully!

    Thank you for trying out WP Mail SMTP. We’re on a mission to make sure that your emails actually get delivered.”

    I uninstalled the plugin and when I reinstalled I still got the “Host must be a string” error… can I send you some log?

    FGD

    (@cedricshaw)

    Same here with GSuite. Following thread waiting on fix.

    • This reply was modified 11 months, 1 week ago by FGD.
    FGD

    (@cedricshaw)

    ok, deactivated the plugin and reactivated to get the latest plugin update. Performed the update and added the authorization. Sent a test email and the error cleared so it does appear resolved. Thanks!

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @cedricshaw,

    Thanks for letting us know. Yes, the version 1.8.1 indeed should’ve fixed the issue.

    @jobsinasia, if you’re still having any issue, please let me know.

    Have a good one! 🙂

    helenarouit

    (@helenarouit)

    Hello,

    I have the same error as mentionned above by someone. I’ve deactivated and reactivated the plugin but the error remains:
    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v1.8.1 logged this error during the last time it tried to send an email:

    Mailer: Gmail
    {
    “error”: {
    “errors”: [
    {
    “domain”: “global”,
    “reason”: “required”,
    “message”: “Login Required”,
    “locationType”: “header”,
    “location”: “Authorization”
    }
    ],
    “code”: 401,
    “message”: “Login Required”
    }
    }

    Can anyone help?
    Thanks!!

Viewing 15 replies - 31 through 45 (of 45 total)
  • The topic ‘Email Delivery Error: Mailer: Gmail Host must be a string’ is closed to new replies.