Support » Plugin: WP Mail SMTP by WPForms » Email Delivery Error: Mailer: Gmail Host must be a string

  • Resolved apere125

    (@apere125)


    Configured WP Mail SMTP plugin to connect via Gmail API as described in these instructions.

    Authenticated the App OK but receive the below error message when configuration is saved. Unable to send test email, button is grayed out.
    Cannot find any posts with similar issues. Has anyone seen this before?

    Notes:
    *Google Gmail account has 2FA disabled and Less Secure Apps enabled.
    *No other SMTP configurations work to 3 other email providers…. Have been fighting this module for over 12 hours now…..

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v1.8.0 logged this error during the last time it tried to send an email:

    Mailer: Gmail
    Host must be a string

    Consider running an email test after fixing it.

    • This topic was modified 11 months, 3 weeks ago by apere125.
    • This topic was modified 11 months, 3 weeks ago by apere125.
Viewing 15 replies - 1 through 15 (of 45 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    Hi @apere125,

    Can you please share the domain name where you have configured Gmail mailer? Does it have any sorts of redirects between domains?
    Are you using GSuite or usual Gmail email address?
    If GSuite – are your email addresses look like something@example.com or GSuite is configured to another domain and makes redirects to your current domain?

    I just went to set up a contact form, did the entire OAuth and GSuite process and got my Client ID and Client Secret. Went to send a test email and got the same error. I haven’t seen this anywhere else on any forums. As of the time of writing this, the thread is only 2 hours old and the plugin was updated 8 hours ago, so I wonder if it is an issue with the most recent update or on Google’s side of things?

    This is happening to me too!! Just started happening with the most latest update. I also got this error when trying to connect my account again.

    HELP!!

    Warning: idn_to_ascii() expects parameter 3 to be integer, string given in /home3/clc4ncaz/cbdtechnologies.us/wp-content/plugins/wp-mail-smtp/vendor/guzzlehttp/guzzle/src/Client.php on line 221

    <Button>
    Allow plugin to send emails using your Google account

    Also just a note ive had wp mail smtp running on my site over a year now with no issues until just now, was about to upgrade to premium but now I am not sure- we need this fixed.

    I updated it today now im getting same error as above?
    Do you have rollback version link please?

    • This reply was modified 11 months, 3 weeks ago by jvarain.

    I did the update today now getting this error “There was a problem while sending the test email”. Any idea? Why? It was working good last week. I’m using gmail.

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v1.8.0 logged this error during the last time it tried to send an email:

    Mailer: Gmail
    Host must be a string

    • This reply was modified 11 months, 3 weeks ago by sam1215.

    Wow..Good to know its not just me. I searched everywhere for a similar posting and couldn’t find anything so it does sound like a new issue, I guess.

    @slaffik, Thanks for the reply.
    The domain in question is https://foxtech.us.
    The Google account is a regular public Gmail account. Not GSuite. There is no redirection that I know of.

    Same problem! Would love some help!
    Have had everything working on my site for almost a year…

    • This reply was modified 11 months, 3 weeks ago by kmanrite.

    Also I have not updated today so think the issue is something besides an update

    @kmanrite
    I am on WP Mail SMTP version 1.8.0. For the benefit of the author can you verify what plugin version you are on, if possible?

    WP Mail SMTP 1.8.0
    WP Forms Lite 1.5.7
    WordPress 5.3

    WP Mail SMTP 1.8.0
    WP Forms Lite 1.5.7
    WordPress 5.3.1

    Does anyone have an update?

    Same for me using SendinBlue after the update today…

    Versions:
    WordPress: 5.3
    WordPress MS: No
    PHP: 7.2.25
    WP Mail SMTP: 1.8.0

    Params:
    Mailer: sendinblue
    Constants: No
    API Key: Yes

    Debug:
    Mailer: Sendinblue
    Host must be a string <<<<<———

    Same issue as well.

    WP Mail SMTP 1.8.0
    WordPress 5.3.1

    @nusserstudios
    With Gmail as well?

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘Email Delivery Error: Mailer: Gmail Host must be a string’ is closed to new replies.