Support » Plugin: WP Mail SMTP by WPForms » EMAIL DELIVERY ERROR

  • Resolved ardent12

    (@ardent12)


    I get this error frequently. At least once per week.

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v2.7.0 logged this error during the last time it tried to send an email:

    I remove/reset the connection, and it works for a while but it is a temporary fix. It has happened a few times now.

    Why do I get this repeatedly?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Gregor Capuder

    (@capuderg)

    Hi @ardent12,

    I don’t see the actual error message you are getting, but I guess you are using the Gmail mailer and the error is saying something along “token has expired”, right?

    One of the main things that could cause this issue is if your Google/Gmail API app is in “Testing” mode. Could you please check if the Google API project is in the “Production” mode by going to the Google API console, opening the project for our plugin integration, then go to “OAuth Consent Screen” and check the “Publishing status”. More info can be found in this screenshot. It should say “In production”. If it says “Testing”, please switch it to the “In Production”.

    Then go to the plugin settings, remove the connection, and re-connect once more. This new connection (tokens) should not expire after one week now.

    Let us know how it goes.

    Have a nice day!

    Thread Starter ardent12

    (@ardent12)

    This is the exact message:

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v2.7.0 logged this error during the last time it tried to send an email:
    Mailer: Gmail
    {
    "error": "invalid_grant",
    "error_description": "Bad Request"
    }
    Please re-grant Google app permissions!
    Go to WP Mail SMTP plugin settings page. Click the “Remove Connection” button.
    Then click the “Allow plugin to send emails using your Google account” button and re-enable access.
    Consider running an email test after fixing it.

    Is your advice still the same?

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @ardent12,

    yes, please check out the things I mentioned above and let me know how it goes.

    Have a nice day!

    Thread Starter ardent12

    (@ardent12)

    Ok thank you for pointing that out. I’ll cross my fingers that I won’t have to do it again 🙂

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @ardent12,

    So, your Google OAuth app was in “Testing” mode then?

    Please check the connection in a week (or 10 days) and let us know if everything is OK.

    Have a nice day!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.