WordPress.org

Forums

Subscribe2
email delivery (9 posts)

  1. bmp1
    Member
    Posted 10 months ago #

    We are trying to troubleshoot email delivery. We have latest version of Subscribe2 and Email Log plugin confirms all emails are sent. Unfortunately, some Registered Subscribers fail to receive them.

    Our host provider (we are on a Managed VPS plan) has advised this:
    "We are not blocking any of the emails that you send through WordPress; however, if you are sending them through WordPress they are most likely being sent via php mail() function. Most receiving mail servers will either reject email sent as php mail() or place them in spam due to the lack of email headers. The below URL provides more details on adding header information to your php mail script.

    http://stackoverflow.com/questions/5935087/how-do-i-prevent-mails-sent-through-php-mail-from-going-to-spam "

    Any thoughts on their response and/or solutions?
    Bu the way, no problem with emails for public subscribers.

    Thanks.

    https://wordpress.org/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 10 months ago #

    @bmp1,

    Subscribe2 uses the core WordPress wp_mail() function which in turn uses the PHPMailer library. These together make sure that all email headers are constructed. If the issue was with the headers you would see deliverability issues with the Public Subscribers too.

    I suspect some of your Registered Users are not fully Subscribed. Have a look in their settings by clicking 'edit' below their email address at Subscribe2->Subscribers and check.

  3. bmp1
    Member
    Posted 10 months ago #

    I suspect some of your Registered Users are not fully Subscribed. Have a look in their settings by clicking 'edit' below their email address at Subscribe2->Subscribers and check.

    No, they are subscribed there: All Subscribed Categories

    Here is a further update from our service provider when they checked their email log:

    The message is being rejected as the receiving mail server is trying to verify the sender servername@server.xyz.com and failing. We would recommend changing your mail script to send out from an email address that is set up on your account.

    I am not sure why they are saying that as the From setting in Subscribe2 is:
    bolgname@xyzcompany.com and not servername@server.xyzcompany.com

    Any thoughts on this?

    Thanks

  4. mattyrob
    Member
    Posted 10 months ago #

    @bmp1,

    If your emails are being sent on your blog server the email address may need to be very specific. If you are sending the emails as if they are coming from a real email address - one that actually exists and has an accessible inbox, try using Configure SMTP or a similar plugin to force the emails via an authenticated SMTP server rather than your blog webserver.

  5. Moter Power
    Member
    Posted 10 months ago #

    How can include my privacy policy into the email reply once a user has signed up?

    Thanks

  6. mattyrob
    Member
    Posted 10 months ago #

    @Moter Power,

    Thanks for the question but...

    1) As per the forum rules, you should have opened your own thread.
    2) "email reply once a user has signed up" doesn't make any sense, Subscribe2 does not send a confirmation email to the user after they confirm their subscription, it's displayed on your site.
    3) If you meant that you want to amend the message displayed on your site, you can through the plugin API, specifically the 's2_subscribe_confirmed' and 's2_unsubscribe_confirmed' hooks.

  7. bmp1
    Member
    Posted 10 months ago #

    Before I try the Configure SMTP suggested, our host provider is advising "email address, it doesn't appear to be authenticating":

    Even though it's configured to send from a specific email address, it doesn't appear to be authenticating. un-authenticated email sent from a script would be sent as the cPanel user rather than the email address itself.
    You may need to check and make sure SMTP authentication has been configured and is actively being used http://email.about.com/od/emailprogrammingtips/qt/PHP_Email_SMTP_Authentication.htm

    Sounds like Configure SMTP may still be the answer but I wanted to add above response by my host provider in case you had anything to add.

  8. tanaylakhani
    Member
    Plugin Author

    Posted 10 months ago #

    Yes, you need to use configure SMTP

  9. bmp1
    Member
    Posted 10 months ago #

    Wanted to follow up and report that "Configure SMTP" did resolve the problem. Once emails were authenticating all emails were delivered except the spam or bad addresses ones. And now I'm receiving bounced email notifications (unlike before).

    Thanks for the help.

Reply

You must log in to post.

About this Plugin

  • Subscribe2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic