Support » Plugin: Simply Schedule Appointments – Booking Calendar » Email, calendar, and modification issues

  • Resolved hanszamorano

    (@hanszamorano)


    First of all, thanks you for this awesome plugin.

    Installed SSA v2.4.3.2 (basic) some days ago and we are experiencing some issues:

    • Emails are not working correctly. For example, I am using 3 emails to test: admin@domain.com, my_email_1@gmail.com, my_email_2@gmail.com. On admin notifications I use the default admin email by the default interpolation “{{admin_email}}”, and manually added my_email_2@gmail.com as a co-recipient. On customer notifications I send to my_email_1@gmail.com which is obtained by the interpolation “{{customer_email}}”. When scheduling an appointment, or cancelling them, just my_email_1@gmail.com receives notifications. I tested using only {{admin_email}} which is the default, without CC, and nothing happens on Admin email (that’s why tested with other two emails). When receiving admin notifications at my_email_1@gmail.com as CC, it says it is sent to admin@domain.com, and my_email_2@gmail.com, just copied that and resended to them and it worked. The workaround I’m using right now is to not use admin_email interpolation and write them manually. I would say is a server level malfunction, but when not using the interpolation all works perfectly. Note that in both cases the emails are being sent instantly in the next minute since the event (scheduling, or cancelling).
    • Cancelled appointments are not being removed from calendar, just prefixes “Cancelled:” to the event.
    • When editing appointment information, it says the phone number it’s invalid, in this case I rewrite one number, or add and delete one to “refresh” the validation of the field.
    • Appointment modification event in notifications is not working, when modifying an appointment, just cancels and reschedules.

    If you think I should be creating different threads for each issue, please let me know.

    Thanks in advance 😉
    Best regards

    • This topic was modified 2 months, 2 weeks ago by hanszamorano.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter hanszamorano

    (@hanszamorano)

    If this is useful,

    By instance made a hotfix to handle the Google Calendar event deletion when user or admin cancels the appointment:

    
    // File: wp-content/plugins/simply-schedule-appointments/includes/class-google-calendar.php, line 499 at the end of sync_appointment_to_calendar function
    // Original:
    $calendar_event_id = $this->update_event( $calendar_event_id, $event, $calendar_id );
    
    // New
    if( $status === 'canceled' ) {
        $this->delete_event($calendar_event_id, $calendar_id);
    } else {
        $calendar_event_id = $this->update_event( $calendar_event_id, $event, $calendar_id )
    }
    

    Any information about this issue or the others is appreciated,
    Thanks in advance 😉

    • This reply was modified 2 months, 2 weeks ago by hanszamorano.
    Plugin Contributor Natalie MacLees

    (@nataliemac)

    Hello @hanszamorano ,

    Sorry to hear that you’re experiencing some issues with the plugin. If you’re using our Google Calendar integration, it sounds like you’ve upgraded to one of our premium plugin editions and are entitled to priority support through our support@simplyscheduleappointments.com email address if you’d prefer to use that instead of the forums. Sometimes that’s helpful for sharing some information that can help us debug that you wouldn’t necessarily want posted publicly to the forums.

    I’ll address the issues you’re reporting below.

    Emails are not working correctly. For example, I am using 3 emails to test: admin@domain.com, my_email_1@gmail.com, my_email_2@gmail.com. On admin notifications I use the default admin email by the default interpolation “{{admin_email}}”, and manually added my_email_2@gmail.com as a co-recipient. On customer notifications I send to my_email_1@gmail.com which is obtained by the interpolation “{{customer_email}}”. When scheduling an appointment, or cancelling them, just my_email_1@gmail.com receives notifications. I tested using only {{admin_email}} which is the default, without CC, and nothing happens on Admin email (that’s why tested with other two emails). When receiving admin notifications at my_email_1@gmail.com as CC, it says it is sent to admin@domain.com, and my_email_2@gmail.com, just copied that and resended to them and it worked. The workaround I’m using right now is to not use admin_email interpolation and write them manually. I would say is a server level malfunction, but when not using the interpolation all works perfectly. Note that in both cases the emails are being sent instantly in the next minute since the event (scheduling, or cancelling).

    Can you please double-check the admin settings to be sure that the admin email address is correct there and there isn’t a typo or other issue with it? From the WordPress dashboard, go to Appointments > Settings > General Settings and make sure the admin email is correct. We haven’t any other reports that using the token for the {{admin_email}} when addressing the emails has caused any deliverability issues, so I suspect that there’s just a typo here.

    Cancelled appointments are not being removed from calendar, just prefixes “Cancelled:” to the event.

    This is correct and is working as intended. In addition to having Canceled prepended to the event title, the Google Calendar event is also changed from Busy to Free so that it is not blocking any other events from being booked into the canceled spot.

    When editing appointment information, it says the phone number it’s invalid, in this case I rewrite one number, or add and delete one to “refresh” the validation of the field.

    I’ve verified that this is the case and we’ll include a bug fix for this in a future release of the plugin.

    Appointment modification event in notifications is not working, when modifying an appointment, just cancels and reschedules.

    Can you clarify this one? Are you selected to Reschedule the appointment? Or just to edit the appointment information? If you’re rescheduling, then it’s correct that we book a new event, and then cancel the old one. This helps to avoid a number of potential complications with just adjusting the date/time/appointment type/duration of an existing appointment. If you’re just editing information like the customer name or email address and that’s resulting in the appointment being canceled and a new one booked, then that’s a bug that we haven’t seen before and we’ll work with you to sort out what’s going wrong there to get that corrected.

    Thread Starter hanszamorano

    (@hanszamorano)

    Hello Natalie,

    Thanks for your response :D, and sorry for not seeing the premium advice. I will answer by email, as suggested.

    Best regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.