Support » Plugin: Email Encoder - Protect Email Addresses » email as attribute in webaddress link

  • giorgiation

    (@giorgiation)


    Hello,
    I´m using this string to have a link to wetransfer page, with the destination email included:
    link to wetrasfer with email.
    After one day of troubles I finally found out that the email-encoder plugin is changing this and prevent to work, unless the plugin is disabled.
    Do you have any suggestion ?
    Thanks in advance
    Gio

    • This topic was modified 11 months ago by giorgiation.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Ironikus

    (@ironikus)

    Hey @giorgiation – thank you a lot for reaching out to us!

    I checked on your issue and it seems that the URL you use the email in, is not properly formatted (No standardized HTML).

    To make it work again, there are two different solutions I can recommend to you:

    1. Properly format the URL
    For what I can see, your URL looks something like: https://www.wetransfer.com/to=test@test.com
    For what I can see, there’s two mistakes in the URL:

    1. The questionmark for defining GET parameter is missing. I assume the to is a GET parameter within the URL, correct? If so, the URL should look something like this: https://www.wetransfer.com/?to=test@test.com
    2. The second issue I see is that the @ sign is not escaped for URL parameters, which causes the initial problem. To make this work, please change it to https://www.wetransfer.com/?to=test%40test.com (Change the @ to %40)

    Once you made these changes, the plugin should work as expected.

    In case you can’t change the values above, here’s another solution that makes it work:

    2. Simple entity encoding
    Within the settings of our plugin, you will find a group called
    Protect emails using. In there, you will find a radio button for simple HTML character encoding. – Please choose this one and save the settings.

    This causes to only use entity encoding (which is not the best, but does its job).

    I recommend you to try the first solution and if that is not possible, go with the second one.

    If you have further questions on that, feel free to reach out again. 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘email as attribute in webaddress link’ is closed to new replies.