Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence Email Alerts Marked Spam by Gmail

  • Resolved junkofdavid2

    (@junkofdavid2)


    Hi guys,

    Just a heads up. All your legit email alerts always end up in my Gmail spam folder.

    I’ve many times in the past month clicked “Report Not Spam” hoping the Gmail algo will stop marking it as spam, but it still does.

    Dunno if you can somehow inform Gmail about it.

    Regards

    • This topic was modified 10 months, 1 week ago by junkofdavid2.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @junkofdavid2,

    Wordfence uses wp_mail to send its email alerts. The emails that are being sent from your server’s SMTP settings.

    You may want to look into different options such as a SMTP WordPress plugin, or renting a SMTP server that you can send emails from.

    If when you rented your host, it came with email service, you could ask your host provider for more assistance.

    Dave

    Thanks Dave.

    1) But the issue is always “contains a link which was used to steal other people’s information” and the only link is

    https://www.wordfence.com/zz1/wordfence-signup/

    To change your alert options for Wordfence, visit:
    Mysite(dot)com/wp-admin/admin.php?page=Wordfence&subpage=global_options
    To see current Wordfence alerts, visit:
    Mysite(dot)com/wp-admin/admin.php?page=Wordfence

    2) Moreover, the other email notices sent from my website (Woocommerce stuff, etc.) go to the proper inbox.

    Do you still think it’s my server’s SMTP settings?

    Let me know.

    Regards
    junkof

    • This reply was modified 10 months, 1 week ago by junkofdavid2.
    Plugin Support wfdave

    (@wfdave)

    Hi again!

    I have some options you can try in order to get the emails into your inbox.

    1. Try whitelisting the email from within Gmail

    2. If it is caused by the wordfence signup link, you can edit that snippet out of the email.

    Go into /wp-content/plugins/wordfence/lib/email_genericAAlert.php and remove lines 9-22.

    The section is as follows:

    <?php if(! $isPaid){ ?>
    	<?php _e('NOTE: You are using the free version of Wordfence. Upgrade today:
     - Receive real-time Firewall and Scan engine rule updates for protection as threats emerge
     - Real-time IP Blacklist blocks the most malicious IPs from accessing your site
     - Country blocking
     - Two factor authentication
     - IP reputation monitoring
     - Schedule scans to run more frequently and at optimal times
     - Access to Premium Support
     - Discounts for multi-year and multi-license purchases
    
    Click here to upgrade to Wordfence Premium:
    https://www.wordfence.com/zz1/wordfence-signup/', 'wordfence'); ?>
    <?php } ?>

    Dave

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Wordfence Email Alerts Marked Spam by Gmail’ is closed to new replies.