Support » Plugin: Knews Multilingual Newsletters » Email address seems to be incorrect

  • Hey there,

    great plugin, everything seems to be working except for this old bug.

    When trying to subscribe I always get that error message:
    “Your e-mail address seems to be incorrect. Please check it back”

    I found other topics discussing this error:
    – the plugin is added as widget in my footer area
    – I turned off the Clean lists feature
    EDIT:
    – there are no caching plugins installed

    HUGE EDIT:
    It somehow occurs only in Chrome (on OSX)! Tested in Safari and FF, both tell me that the mail is already registered (I added the “testaddress” via the backend).
    Clearing browser cache in chrome and logging out of backend did not help.

    Thankful for any help! 🙁
    Thomas

    https://wordpress.org/plugins/knews/

Viewing 12 replies - 1 through 12 (of 12 total)
  • This also happens in Firefox. It keeps telling me that the email address is wrong. I can’t use the widget to get new subscribers.

    Deleting the cache created by WP Fastest Cache seems to work (???) So perhaps adding the js file from knews to the exception rules of WP Fastest Cache could work.

    • This reply was modified 4 years, 6 months ago by Jack.

    Adding the javascript file to the exception rules did not work. The widget tells me again that the email address I entered is wrong. Is there something else I should exclude???

    On our site the same issue arises with Chrome, and Safari suspected. Firefox and IE don’t have any issues.

    It appears to be happening at line 714 of knews.php:

    if ($this->post_safe(‘knewscomment’) != ”) $stupid_bot = true;

    Somehow the post_safe function is recognizing a Chrome user entering a valid e-mailaddress as a stupid bot.

    By the way, it happens with 1.8.2 as well as 1.8.1. I don’t have older versions to test it with.

    • This reply was modified 4 years, 3 months ago by rmast.

    Chrome automatically enters my home-address in the invisible knewscomment-field meant for spammer-recognition. I guess Safari does the same. I commented the line out.

    However, I suspect this subscription-widget to be deprecated by the Contact form 7 glue, which provides for a subscription form with ReCaptcha-spamprotection.

    Hi,

    I am facing this problem too (Your e-mail address seems to be incorrect. Please check it back.). I have disabled the Contact form 7 glue, however, I still get this message.
    Has anyone found the solution?
    I would be grateful for it!

    Milada

    I am experimenting with line 714 of knews.php to get it more intelligent.

    I just changed it to:
    if ((strpos($this->post_safe(‘knewscomment’), ‘http://’) !== false)||(strpos($this->post_safe(‘knewscomment’), ‘!’) !== false)) $stupid_bot = true;

    It keeps lots of spammers out now, but probably also people with http:// or ! in their house address. I guess there won’t be many of them.

    By the way, I still haven’t replaced this widget with Contact Form 7 as the Google Captcha doesn’t color right with our current website. It only provides some black and some grey facing.

    • This reply was modified 4 years, 2 months ago by rmast.

    Watch out when copying the line above, the apostrophes have been replaced.

    By the way, in the KNews-professional version it should replace line 720.

    The knews-way of handling subscription-spammers doesn’t filter out lots of spammers.
    I have experimented with the API at stopforumspam.com, and blocking spammers on a stopforumspam-IP-query seems to be more effective than the current knews-way of blocking them. I’ll leave it running for another week and then upload a minimal difference to Github.

    After a week the filtering result of first IP and then EMAIL right at the moment of subscription gives from almost 100 spam e-mails 5 non-spam subscriptions passing. The subscribers that do not pass stopforumspam are really all spammers, and the subscribers that pass all look quite trustful, even one foreign looking address. So within a week a spamcheck right at the moment of subscription is still sufficient for perfect filtering.

    So, after a week there is still no proof a job that checks spammers later on, which I previously programmed is necessary. At the time of subscription all spammer IP-addresses or e-mailadresses are already known at stopforumspam.com, and no real subscriber comes via a blocked IP.

    I uploaded the StopForumSpam-diff to 1.8.2 to github, this makes the subscriberwidget function almost perfect without the use of an ugly Google Captcha.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Email address seems to be incorrect’ is closed to new replies.