Support » Plugin: Email Address Encoder » Email Address Encoder and PHP 8.2

  • Resolved gkellerzh

    (@gkellerzh)


    HI there

    I just switched to PHP 8.2 and get these Errors on all pages (also backend):

    Deprecated: Creation of dynamic property Email_Encoder_Settings::$template_tags is deprecated in /home/clients/ba775250121e28e94a6143b8d426c9f7/web/sandkasten.fr/wp-content/plugins/email-encoder-bundle/core/includes/classes/class-email-encoder-bundle-settings.php on line 164

    Deprecated: Creation of dynamic property Whip_RequirementsChecker::$configuration is deprecated in /home/clients/ba775250121e28e94a6143b8d426c9f7/web/sandkasten.fr/wp-content/plugins/sitepress-multilingual-cms/vendor/yoast/whip/src/Whip_RequirementsChecker.php on line 37

    Deprecated: Creation of dynamic property Whip_RequirementsChecker::$messageManager is deprecated in /home/clients/ba775250121e28e94a6143b8d426c9f7/web/sandkasten.fr/wp-content/plugins/sitepress-multilingual-cms/vendor/yoast/whip/src/Whip_RequirementsChecker.php on line 38

    Does anyone else experience this?
    Probably this could be easily fixed in an update.
    I would prefere to use PHP 8.2 for faster processing.
    WP-Version: 6.4.3
    Installed Plugins:
    Contact Form 7
    Contact Folrm 7 Multilingual
    Email Encoder
    Open User Map
    WPML Multilingual CMS
    WPML String Translation

    Thanks for any hints!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Hey!

    These messages are related to “email-encoder-bundle” not to this plugin (email-address-encoder).

    Thread Starter gkellerzh

    (@gkellerzh)

    Oh, you’re so right! Sorry for that!
    It anway seems to be to early to switch to PHP8.2. Happily back on 8.1…

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.