Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @charisma21

    I hope you’re well today!

    The last issue isn’t really an issue. The “DevTools failed to load SourceMap” error is specifically related to using webdeveloper tools and does not affect site in any way. It’s only visible if browser webdeveloper tools are used.

    To be specific: it only happens then. It’s not that it’s hidden otherwise but it just doesn’t happen. The “map” files are special files that help browser present minified file in a “human-readable” form (unminified) and that’s it, they are not required and not needed for anything else on site. You can safely ignore it.

    As for “render-blocking” resources – you are right, based on filenames some of these files are already compressed/combined but that only speeds up loading and doesn’t affect “render blocking” much.

    In order to deal with “render-blocking” issue as much as possible, you would want to switch Asset Optimization option in Hummingbird from Automatic to Manual (make sure to check the “apply configurations” checkbox when doing it) and you’ll see a list of CSS/JS files.

    Next to each file there’ll be a set of button, first two (from left to right) being “compress” and “Combine”. Last one (on the right) is to not load the file at all. ignore those, keeping them as they are and focus on the buttons between them.

    They are for moving file to the footer/inline (for CSS) and moving to footer/loading after page is loaded (for JS). You might need to experiment a bit with them but the goal is to move as many files to footer and load as many JS scripts after page is loaded as possible without breaking the site.

    Note please: among the files that you listed there are also Google Fonts related files that are loaded from external source. Hummingbird only deals with JS/CSS files so that can’t really be addressed this way.

    You could, however, give this free plugin a shot to address Google Fonts:

    https://wordpress.org/plugins/host-webfonts-local/

    Best regards,
    Adam

    Thread Starter charisma21

    (@charisma21)

    Hi Adam!

    Oh wow, thank you so much for your effort and this very indepth answer. I will try my very best!

    About moving files: I reached one point where my performance scores got up to 91 and 98 but it only loaded the html. I actually don’t know why because I didn’t move any of the theme files into the footer. Do you have any idea what could have caused this?

    Also after moving some of the CSS files into the footer the performance score got worse instead of better. At this stage, when moving files to footer/inline/force delayed loading: Do I still need to have cache switched off?

    Thank you so much!

    Best regards,
    Clara

    Plugin Support Jorge – WPMU DEV Support

    (@wpmudevsupport15)

    Thank you for following up, @charisma21.

    Do note that if something fails when you move a file to footer it means that the best option is to leave it loading from the header as it’s an important file.

    Once you have a good combination of settings and your site works correctly, then activate caching to see how it behaves.

    Let us know how it goes.

    Regards,

    Jorge

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @charisma21,

    Since we haven’t heard from you in a while, I’ll mark this thread as resolved for now. Please feel free to re-open the thread if you need further assistance.

    Best Regards
    Nithin

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.