Support » Plugin: Disable Gutenberg » Eliminate Render-Blocking Resources

  • Resolved TKphotography


    Greetings and thank you for your plugin. I am trying to optimize a website using Chrome’s Lighthouse tool. Even though I have installed and set up the Disable Gutenberg plugin, I still see a lot of Gutenberg related dependencies being loaded. Is there a way to disable these dependencies from loading by using this plugin?

    This file is being loaded even though it shouldn’t.

    Thank you in advance!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeff Starr


    Glad to help. You can disable those frontend Gutenberg scripts by toggling open the “More Tools” settings. Then uncheck the box that says “Enable Frontend”.

    Thank you for your quick reply. I did disabled it now cleared cache etc, but Lighthouse keeps reporting that these files are being loaded. I see them in “Remove Unused CSS” Section of the lighthouse.
    There are 4 css files that are being loaded but I use 0 code from them. All of them are in “dist” directory which as far as I can understand is related to Gutenberg.

    The list of files are:

    Plugin Author Jeff Starr


    With the “Enable Frontend” option *unchecked*, I am not seeing any of those files included using the default WP Twenty Twenty theme. So it could be theme-related, have you tried testing your theme?

    It worked for me …I had a rough time with Gutenberg, It messed up my site
    A big thank you!

    I am getting render-blocking codes as well. (see below) how can I fix them?














    Plugin Author Jeff Starr


    @decadebetween Disable Gutenberg plugin can only help with the block-related scripts and styles. For all of those others that you list, you will need to contact a developer who can help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.