Support » Plugins and Hacks » Autoptimize » Eliminate Render Blocking CSS

Viewing 15 replies - 121 through 135 (of 141 total)
  • Plugin Author Frank Goossens

    (@futtta)


    well, your critical (above the fold) CSS seems to be insufficient to render the visible part the page correctly Janine, try re-generating the CSS. if you can fix that, you should be able to have at least the 2 autoptimized files removed from the render-blocking list.

    the blocking devicepx-jetpack.js and allbiz_expand2web_css_header css however will remain render blocking (the JS is external, the CSS is dynamic).

    hope this clarifies,
    frank
    (it’s not my video, you have to thank aj@wpfaster for that 🙂 )

    Sorry to post this in here, but how do I stop getting all the replies via email now?

    Plugin Author Frank Goossens

    (@futtta)


    @evlttwinn999: left-column -> topic info -> unsubscribe? 🙂

    Duh, thanks!

    when activate “deffer in line css” option in autoptimize my theme broken.

    so genarate critical css and paste in deffer box realy works, but broken my theme.

    is there another way to eliminate render block ?

    the only css blockin render file (in page speed report) is generated by autoptimize, naturally.

    any suggestion ?

    nice plugin!

    thank you

    Plugin Author Frank Goossens

    (@futtta)


    you can try “inline all CSS” @faninja, not ideal (esp. if you would have a lot of CSS), but still ..

    i´ve try this frank, but “inline all css” broken theme more than “inline deffer css” …

    and “in line all cc” not remove render block penalty …

    Plugin Author Frank Goossens

    (@futtta)


    and “in line all cc” not remove render block penalty …

    then you must have something else blocking: if you inline all css, there’s not autoptimized CSS file linked any more and if there’s no linked CSS-file, it can’t be render blocking 🙂

    Sorry frank, I wanted to say that “in line css” causes penalty of “Prioritizing visible content”

    This option actually removes the rednder block penalty but causes the Prioritize visible content penalty

    Do you have any suggestions for this?

    Hi Frank

    Thanks to your autoptimize I achieved a 100/100 score on a simple site: intensive-driving-sussex.co.uk

    My probelm now is I’m using beaver builder for another site and have read in your FAQs:

    Visual Composer, Beaver Builder and similar page builder solutions are broken!!

    These page builder plugins run on the frontend for logged in users and are very JavaScript intensive and should not be optimized. You can tell Autoptimize not to act on these page-builder powered pages for logged in users with this code:

    The thing is I have no idea of where to put the code Can you help.

    Thanks again

    Plugin Author Frank Goossens

    (@futtta)


    @faninja; that’s true, that is because there’s too much CSS to inline, in which you will have to find a way to “inline & defer” anyway. not always easy though ..

    @bouyo; best way (least risk) is to install the code snippets plugin and add it in there.

    ok frank, thank you.

    Thank you for that

    Hi there,

    Just installed Autoptimize and used it to eliminate render blocking CSS. Now the only issue I’m having is:

    Optimize CSS Delivery of the following:
    http://maxcdn.bootstrapcdn.com/…4.5.0/css/font-awesome.min.css?ver=4.5.0

    I’ve searched online for an hour trying to find a solution, but can’t seem to find one, and this thread seemed promising.

    Any advice for a wordpress newbie (read: learning to code slowly, so might step by step instructions on this one)?

    Any help is much appreciated!

    Plugin Author Frank Goossens

    (@futtta)


    no easy fix for that @galensim; you would have to deregister/ dequeue the maxcdn-version of font-awesome and register/ enqueue it locally to allow AO to aggregate it. not really a newbie-job I’m afraid.

Viewing 15 replies - 121 through 135 (of 141 total)
  • You must be logged in to reply to this topic.