WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Elfinder – "Invalid Backend configuration"

[Resolved] Elfinder – "Invalid Backend configuration"

  • wickywills
    Member

    @wickywills

    Hi, I’m new (and I mean new!) to WordPress, and I have it running locally on a Windows machine (localhost, IIS 7), and it’s working perfectly fine except for a file manager plugin called “elFinder”.

    Basically when I start it, I just get an error “Invalid Backend configuration”, and when I run Firebug on it, I get an “Internal server error 500”. Is this simply because elFinder doesn’t run locally, or is it something else?

    I have already installed “JSON API” (which apparently is required by elFinder).

    any help greatly appreciated!

Viewing 2 replies - 1 through 2 (of 2 total)
  • same problem here.
    anyone?

    CZ_SaLIk
    Member

    @cz_salik

    In my 3.2.1 wordpress file manager in administration don’t show (when i was tested it on localhost pc) -> i just get an error “Invalid Backend configuration”

    therefore i was updated begin of the file connector.php like this:

    //get dirname
    $actfile = dirname(__FILE__);
    //replace "\" with "/" if there is some
    $actfile = str_replace("\\", "/", $actfile);
    
    //Loading WordPress and plugin environment
    include_once(str_replace("/wp-content/plugins/wp-elfinder/elfinder/connectors/php", "", "$actfile/wp-load.php"));
    include_once(str_replace("/elfinder/connectors/php", "", "$actfile/mediator/includes/auxiliary-functions.php"));

    next problem was function _CheckArchivers in elFinder.class.php because this action is too long (on my Win os) and any files shows in the file manager

    so i updated function _CheckArchivators() like this:
    [Code moderated as per the Forum Rules. Please use the pastebin]

    sorry for my bad english 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Elfinder – "Invalid Backend configuration"’ is closed to new replies.