Support » Plugin: OoohBoi Steroids for Elementor » Elementor\Scheme_Typography is deprecated

  • Resolved jhilterman

    (@jhilterman)


    Installed and immediately getting this error from WordPress:

    Deprecated: Elementor\Scheme_Typography is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Typography instead.

    Any ideas?

    Elementor 3.2.2
    PHP 7.4
    Wordpress 5.7.1

Viewing 12 replies - 16 through 27 (of 27 total)
  • Hi everyone
    I have the same problem. I think it is related to oceanwp blog grid

    Elementor\Scheme_Typography is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Typography instead. 1
    wp-includes/functions.php:5051

    Plugin Author Oooh Boi

    (@ooohboi)

    Just use the FIND IN FOLDER tool of the Visual Studio Code (or whatever coding tool you got), let it find the “Elementor\Scheme_Typography” keyword inside of your WP website folder (that includes Plugins and Themes), and you’ll find the troublemaker.
    I’m 100% sure that it doesn’t come from SFE.

    Olá galera.

    Este problema começou a aparecer pra mim quando identifiquei que foi instalado em meu servidor um sistema chamado AnonimousFox. Dentro de meu diretório diversos plugins de scan foram instalados.

    Exclui todos os arquivos que não foram instalados por mim e logo depois começou a aparecer esse problema.

    Para resolver este problema simplesmente entrei na página inicial pelo elementor e atualizei a página. Assim voltou a funcionar normalmente. Espero que também resolva para vocês.

    I have the exact same problem.

    [28-Jul-2021 15:15:31 UTC] PHP Deprecated: Elementor\Scheme_Color is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Color instead. in /home/a581958/public_html/wp-includes/functions.php on line 5273
    [28-Jul-2021 15:15:37 UTC] PHP Deprecated: Elementor\Scheme_Color is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Color instead. in /home/a581958/public_html/wp-includes/functions.php on line 5273

    I’ve updated the plugin and need to update the php level to accommodate other needs on the site. Help would be appreciated.

    Hello everyone,

    In the wp administration panel, go to the setting of Elementor, General,
    check on:
    1: Disable default colors.
    2: Disable default fonts.

    and there you have it, the problem solved.

    Hi, you can hide debug mode in wp-config.php file. Find the line: define(‘WP_DEBUG’, true);
    and change for:
    define(‘WP_DEBUG’, false);

    That way you won’t solve the problem, but at least hide the error message.

    I change this WP_DEBUG, FALSE Into WP_DEBUG,TRUE now kindly resolve my price issue…

    I had the same error before.

    And the problem was the ‘Master Addons for Elementor’.

    ‘wp-includes/functions.php on line 5401’

    hello friends, I had the same problem too, but I resolved it now, I think I found the right reason and resolved it forever, no matter it will happen again or not.

    “datetime=”2021-10-08T08:36:47+00:00″>Elementor\Scheme_Typography is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Typography instead. 1
    wp-includes/functions.php:5051”

    some one’s problem may occur in different line numbers: 5041/5051/5401.
    follow my next steps to find your problem and resolve it:
    1, see where the notice showing on your website page. like mine was showing on the HEADER part, which means the problem is in this part.
    2, check if you are using the default section(example: header section) of your template(which you buy from Astra/ThemeForest or somewhere else, and check the publishing time), I found that the section was published in 2018, and the update of the Elementor version 2.8.0 is later than this time, so I delete the default section instead of editing it. And create a new one for it.
    3, before you delete the default one, you should create a draft one to test, and only keep the old one in the draft, in case something else working happens.
    4, save and check.
    it works for me, hope it helps you a little.
    My online business website is ashleyhairextensions.com.

    • This reply was modified 1 year, 1 month ago by biaojuok.

    and it is not good to only change the WP_DEBUG, FALSE Into WP_DEBUG, TRUE, I suggest

    mrcreatrix

    (@mrcreatrix)

    Use only this type of controls in making custom widgets.

    $this->add_group_control(
        Group_Control_Typography::get_type(),
        [
           'name' => 'title_content_typography',
           'label' => __('Title Normal Typography', 'iqonic'),
           'selector' => '{{WRAPPER}} .title',
        ]
     );
    • This reply was modified 1 year ago by mrcreatrix.
    Moderator tobifjellner (Tor-Bjorn Fjellner)

    (@tobifjellner)

    @andreasemo @vikasmd101
    Please do not jump into other topics and detract from their problem. If the troubleshooting already posted made no difference for you, then, as per the Forum FAQ, please post your own topic. A lot more people will see your post, and that way you stand a good chance of getting the assistance you want. Despite any similarity in symptoms, your issue is likely to be completely different because of possible differences in physical servers, accounts, hosts, plugins, theme, configurations, etc. Thus one problem, on one setup is not indicative of the functionality and reliability of an application as a whole. Your post will be archived.

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Elementor\Scheme_Typography is deprecated’ is closed to new replies.