Support » Plugin: The SEO Framework » Elementor with Sitemap

  • jaspear

    (@jaspear)


    Hi,

    Can anyone tell me if my sitemap looks OK?

    I am not sure that those Elementor entries should be there, before I was using TSF I didn’t have these on the sitemap list.

    I use Elementor Pro

    Any help will be so appreciated, I am new to TSF coming from Rank Match, and before that Yoast.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Pierre LeBaux

    (@lebaux)

    Hey jaspear, lets jump right into it.

    Can anyone tell me if my sitemap looks OK?

    I am not sure that those Elementor entries should be there, before I was using TSF I didn’t have these on the sitemap list.

    Those Elementor entries should not be there, go to:

    SEO > General Settings > Post Types (tab) > Disable SEO

    From there pick entry called elementor_library and save the settings. Then check your sitemap again. Be sure to clear your cache (Ctrl + R).

    Any help will be so appreciated, I am new to TSF coming from Rank Match, and before that Yoast.

    May I ask why you made the switch TSF? We are of course happy to have you! Let us know if you run into any other problems or have any questions.

    Cheers,
    Pierre

    jaspear

    (@jaspear)

    Great thanks a lot!

    One more thing, in fact it is major…

    If i search google “computer repairs milton keynes” the metas are ignored although set on the homepage section, it pulls content instead. I have set it not to do that. Also the homepage has content that exists as service pages in more detail.

    Also the search result shows a picture picked up else where on my site instead of my logo. I have set my logo. Having issues ranking for repairs and it support page but homepage gets all the ranking although metas not working. Hope can get this sorted.

    I came to TSF to see if I can get snippets sorted and rank on other pages.

    Thanks

    jaspear

    (@jaspear)

    Forgot to say url is https://2upc.co.uk

    Ty

    Plugin Support Pierre LeBaux

    (@lebaux)

    If i search google “computer repairs milton keynes” the metas are ignored although set on the homepage section, it pulls content instead.

    Not much you can do it about it I’m afraid, Google reserves the right to do pick text from your website instead of the meta description.

    Also the search result shows a picture picked up else where on my site instead of my logo.

    Where does the search results show that picture? I’m not aware that Google shows pictures in SERP. I know Facebook can show it when sharing, and the picture looks correct to me (you need fb account to view this).

    Having issues ranking for repairs and it support page but homepage gets all the ranking although metas not working. Hope can get this sorted.

    There is little any plugin can do here for you, since Google decides on its own what website ranks higher. There is plenty you can do, but I think the most important thing is to write longer, more descriptive pages. The blog content is extremely bland. Consider writing a case study about the type of clients you have. Look at what your competition does better. Lastly, backlinks still play a huge role in SEO, so consider digging deeper with tools like Ahrefs and SEMRush (trial or one-month subscription should be enough).

    jaspear

    (@jaspear)

    Where does the search results show that picture? I’m not aware that Google shows pictures in SERP. I know Facebook can show it when sharing, and the picture looks correct to me (you need fb account to view this).

    I forgot to say it’s on a mobile device, on page 1, it shows a slim laptop silver, but it should be my logo 🙁

    Can’t see anywhere to change this, I have checked WP admin in site identity.

    Thanks for advice, will check that other stuff out, any advice on the logo will be great, I have set a logo under social.

    thanks

    jaspear

    (@jaspear)

    hi,

    Any help in to ehy my correct logo dosn’t show on search term “computer repairs milton keynes” will be so appreciated please.

    It has been showing a random picked image. This is not my logo, it is on mobile.

    Thanks

    Plugin Author Sybre Waaijer

    (@cybr)

    Hello!

    Google generally doesn’t use the social sharing meta (they follow the links, though!).

    Google played around with showing the favicon in search–but I believe they removed that since phishers (scam sites) abused this.

    The same goes for the structured data logo. We found that Google only takes logos from well-authored Wikipedia pages, instead of your site.

    If you want Google to show a logo of your business, then you can register one via Google My Business. Before they admit you, Google has to verify your address, and they do that by sending you a postcard with a verification code. This verification process keeps the abusers at bay.

    I hope this helps! Sorry for our belated reply 🙁

    jaspear

    (@jaspear)

    Hi,

    Thanks for reply.

    When I was using Yoash which was three weeks ago it shown my logo.

    I already have a Google my business.

    The search results is not a social result it is my url direct to my site.

    Not sure what to make of this to be honest as this was not ever happening before.

    Will see if changes over time as it is misleading my brand look to visitors 🙁

    Thanks

    WOW, I just discovered that I have /?elementor_library= also in my sitemap 🙁

    I tryed to follow your advice but didn’t find the path “SEO > General Settings > Post Types (tab) > Disable SEO”

    Do I have to disable them from here? >>> https://prnt.sc/wm0aq9

    Will also be a good idea to apply a no index and nofollow to them from here? >>> https://prnt.sc/wm0bgp

    Thanks!!!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.