Support » Plugin: Multiple Page Generator Plugin - MPG » Elementor Widget Link tags not working

  • Resolved eWallz

    (@archonic08)


    Hi, please check this screenshot https://snipboard.io/NIo75D.jpg
    I’m building the template page using Elementor Free version but the required tag not converted into the actual content in most of the Elementor Widget link input.

    Example in screenshot I used the button widget then in the link I put like below:
    https://wa.me/{{mpg_agentno}}
    which should generate https://wa.me/60122121212
    but it becomes https://wa.me/mpg_agentno instead….

    So far in elementor the tags only work in widget title & text content input. All link inputs are not working.

    Can you please check it? thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi.
    It’s not an MPG problem, it’s due to Elementor, which uses native WordPress validators for links. 
    Curly brackets are non-valid symbols in links, so they’re trimmed, and MPG does not recognize mpg_agentno as a shortcode which should be replaced.

    The Best workaround is to use an html block instead of Elementor’s link widget.
    1. Go to devtools (as you do in the screenshot)
    2. Copy html code of the button
    3. Remove link widget, and add block for html code
    4. Paste previously copied html code and paste in block
    5. Replace static parts to shortcodes (if needed)6. Save, and check if it is working for you.
    p.s1: You can remove validation of input data, but your changes will be overridden after each update of Elementor, so it’s not such a good idea.p.s2: Also, you can override links using JavaScript, but it’s not so good for SEO reasons.

    Thread Starter eWallz

    (@archonic08)

    Hi, the HTML code works! thanks a lot.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Elementor Widget Link tags not working’ is closed to new replies.