Support » Plugin: Elementor Website Builder » Elementor updated version 3.0.3 is not working fine

Viewing 12 replies - 1 through 12 (of 12 total)
  • mycommax

    (@mycommax)

    I am having similar problems. I cannot delete sections or widgets properly. Copy & Paste Styles not working properly as well. The fonts are not showing properly as well.
    The entire builder is so buggy after updated to 3.0 onwards. My worst experience using Elementor so far. Hoping that this will be fixed real soon.

    Yes, we have the same problems. We note that, after each big Elementor update, after it have a lot issues and fixes, this is not good!

    When we can expect a real good working Elementor?

    mari27

    (@mari27)

    I have the same problems. When can the bugs be corrected?

    dardress

    (@dardress)

    I just updated too and my elementor messed up all of my fonts settings…..after 3 hours i finally figure out how to fix it.
    You need to go to elementor>tools>version control>Rerun Update Script….this returned all of my previous fonts and colors settings.

    andrejoubert

    (@andrejoubert)

    I have similar problems, the UI is hardly workable anymore. Cannot delete sections and columns, then it deletes sections when I delete a column. After every change you need to save as draft and then reload page to see what elementor decided to do.
    Rerun Update Script makes no difference.

    Astonishing that Elementor can release something that is so broken.

    andrejoubert

    (@andrejoubert)

    Waqas’s video is exactly what I experience. Its a mess

    Thread Starter waqassaleem378

    (@waqas7431)

    The elementor upgraded version has lots of bugs. I fixed it by rolling back the elementor version to 2.9.9.

    andrejoubert

    (@andrejoubert)

    Thanks Waqas, I first tried to go back to 3.0.0, but no luck. I now went back to 2.9.9 and things are back to normal. Much appreciate your feedback!

    insyse

    (@insyse)

    The column error is in the powerpack elements plugin, i have the same problem, i hope update of powerpack to fix the problems

    Thread Starter waqassaleem378

    (@waqas7431)

    Hi @insyse thanks for your feedback, I am not using the power pack plugin and i tried the elementor upgraded version with all the top premium themes( Jupiter X, Astra, Bridge, Phlox Pro, Soledad) and its not working anymore with all of theme. It seems like the upgraded version is no more compatible with the pre-built layouts and all old themes. Just wondering if this is an elementor bug or theme developers have to update their themes to make it compatible with the upgraded version of the elementor.

    Regards

    osamuw

    (@osamuw)

    @waqas7431 , same here. Elementor version 3 is breaking all my sites. I rolled back them back to ver. 2.9.9 and all the sites are working fine. Elementor support response has been very slow, and I suspect that they are dealing with all those issues we’ve been facing. I will stay with the older version until it gets solid.

    snaidero

    (@snaidero)

    Same issues here, Editor is not loading, not even on Safe Mode. Unable to edit most of anything, and I´m even using Elementor Pro.

    Please fix. Will revert to previous version in the meanwhile.

    – SRS

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Elementor updated version 3.0.3 is not working fine’ is closed to new replies.