Support » Plugin: Google Website Translator » elementor pro shortcode not visible

  • Resolved daitarn3


    good morning,
    I have this problem: in Elementor pro I created a “Header” Template.
    I have inserted two sections: one for the Desktop and one for smartphones and tablets (see image).
    this to create a layout visible on all devices.
    unfortunately, however, in the second section your widget is not displayed.
    (if you look at the site with a tablet you see that it is missing)

    I don’t understand what it depends on. do you have a solution?
    thank you

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Prisna



    the problem is how those headers work. They are both present in the final rendered HTML pages, but it shows one or the other depending on the screen resolution.

    Google built this widget in a way that you could have only one language switcher per page.

    By looking at the image you sent, the positioning for mobile and desktop is pretty much the same.

    I’d suggest you to use the widget in a location that’s always displayed in all devices, and with CSS place it up there. You can use:

    Advanced > General > Custom CSS
    #google_translate_element {
    	position: fixed;
    	top: 20px;
    	right: 220px;


    • This reply was modified 11 months, 2 weeks ago by Prisna.

    I found this solution and I think it is useful to know:
    I disabled the view responsive to the affected column based on the terminal: desktop, smartpohne and tablet.

    But there’s one thing I don’t know how to solve:
    appears for a moment “select language” and then changes in the language. This generates an animation, as you can remove “select language”.

    That’s all, thanks

    Plugin Author Prisna


    Sorry, it’s not possible to do that. This is the way Google created its translation widget, so we can’t really change how it works, only Google can.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘elementor pro shortcode not visible’ is closed to new replies.