Support » Plugin: Elementor Page Builder » Elementor pro is stripping out image alt tags

  • Resolved imageco

    (@imageco)


    I’ve created a ton of alt tags for images throughout my site but when they are placed in pages using the image widget the alt tags are removed. If I insert the images using the text widget within the text or by themselves just using the text widget the tags remain intact This is going to kill my seo unless I use the text widget for every image inserted or if the images are inserted using a third party plugin like Master Slider or Essential Grid. I removed every plugin and worked my way back and nothing changed so it doesn’t appear to be a conflict. My site is a portfolio with hundred of images so it’s a huge issue for me. Is this going to be fixed?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • @imageco

    I checked the home page of three of my sites and where the images are placed using the Elementor Image widget, all of the alt tags are there in the “View Source”. There must be something else afoot as this is the first time I have heard about this issue.

    Cheers!
    Lyle

    Thanks Lyle, you were right. I had set up an image optimizer that rewrote the alt tags and even after I had uninstalled it and cleared the cache it continued to mess with things. It wasn’t until I started working locally on another site that I realized what happened.

    Much appreciated, Tim

    You can actually insert alt text on images [in bulk] through installing WP Meta SEO plugin. No hassle.

    • This reply was modified 1 year, 2 months ago by  Louie.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Elementor pro is stripping out image alt tags’ is closed to new replies.