Support » Theme: OceanWP » Elementor & Oceanwp – Form Checkbox Not Displaying

  • Resolved healywebdesign

    (@healywebdesign)


    Hi,

    OceanWp CSS is overriding settings in Elementor when using the elementor Form > Checkbox

    When you insert a Form from Elementor and use the ‘Checkbox’ field, instead of displaying ‘Boxes’ for your choice (selection), it will display as a single line instead.

    thought you guys might want to have a look into this and apply a fix on next update. Screenshot attached.
    https://prnt.sc/mfbvpl

    Kind regards
    Lee

Viewing 15 replies - 1 through 15 (of 19 total)
  • Hello,

    Please try to add the below code to the Customize > Custom CSS section and let me know it fixes the issue or not.

    input[type="checkbox"] {
    -webkit-appearance: checkbox;
    }
    Thread Starter healywebdesign

    (@healywebdesign)

    yes this works
    thank you

    You’re welcome!

    Hello Amit,
    your solution helped also me a lot; thank you.

    Do you think that also the “radio button problem” could be caused by oceanwp?

    If you create two or more radio buttons in elementor form, the visitor in the frontend can click on more than one radio button and all buttons remain checked.
    But this is not the sense of a redio button.

    It would be great if you could find the right code to get it fixed.
    Thank you in advance
    Renato

    @renatope I don’t think oceanwp is causing the radio button problem. Have you checked it with the other theme?

    Hi Amit,
    you are right.
    I just tried it with wordpress standard theme and it has the same error.
    Do you think it is a bug of elementor form?
    It’s strange that nobody is notifying this.

    I’m using the newest version of wordpress 5.2.2
    and the newest version of elementor pro 2.5.11

    Thanks and greetings
    Renato

    Have you reached the plugin support about this issue?

    sorry I thought you are part of the support team. Now I send my request to elementor
    Have a nice weekend

    Yes, I’m from OceanWP support but we don’t provide support for third party plugin. The above issue seems to Elementor related, therefore, I asked you to contact the Elementor support. Hope you understand it.

    Thank you Amit, the Elementor support helped me to solve.
    I hope you can help me in this other issue below.

    I would like to disable the links on categories. Actually if the name of category appears somewhere, there is a link setted to a catagory page.

    I need to show the category name, but it shouldn’t have a link.

    If there is to place a code in the function.php would be great if you can explain me how to do this.

    Thanks so much
    Renato

    Hello,

    Try adding the below code the child theme’s functions.php file to remove the link from the category –

    function no_links($thelist) {
      return preg_replace('#<a.*?>([^<]*)</a>#i', '$1', $thelist);
    }
    add_filter( 'the_category', 'no_links' );

    Another CSS that helped me to get the checkboxes back was this:

    input[type=”checkbox”] {
    display: inline-block !important;
    }

    For the checkbox not showing: Mine is showing but it disappears when checked:

    Before checking:

    [ ] Yes

    After checking:

    Yes

    And can click on it to toggle the checkbox to show/not show.

    • This reply was modified 1 year, 7 months ago by dpetraska.

    Thanks you ! It works perfectly 😉

    The custom CSS helped to get a checkmark to display, but there is still a box inside the checkbox, as if a character was corrupted. See bottom of the contact form on this page: http://moncurconsulting.com/contact/

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Elementor & Oceanwp – Form Checkbox Not Displaying’ is closed to new replies.