Support » Plugin: Elementor Website Builder » elementor left side not working

  • Resolved cavra


    I have i problem with new update 2.5.1
    When I try to edit or create new page it loads elementor but left side, where are create elements truck on loading forever and you can not do anything.

    Last versio was working just fine.

    • This topic was modified 2 years, 6 months ago by cavra.
Viewing 15 replies - 16 through 30 (of 30 total)
  • Thread Starter cavra


    This is confusing.
    People from WOOF – WooCommerce Products Filter said that error is not related to their plugin.
    So, what now?

    Thread Starter cavra



    One of our users gave this solution:

    add_action(‘elementor/widgets/widgets_registered’, function($widgets_manager)

    Thread Starter cavra


    I think this problem is with Elementor.

    I had the same problem with new Elementor Pro version 2.5.4

    Uncaught TypeError: Cannot set property 'controls' of undefined  editor.min.js?ver=2.5.11:2
        at Object.<anonymous> (editor.min.js?ver=2.5.11:2)
        at Function.each (load-scripts.php?c=1&load[]=underscore,jquery-core,jquery-migrate,backbone,shortcode,utils,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1.1:3)
        at Object.success (editor.min.js?ver=2.5.11:2)
        at i (load-scripts.php?c=1&load[]=underscore,jquery-core,jquery-migrate,backbone,shortcode,utils,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1.1:3)...

    The reason was in “JNews – Essential” -plugin (Advertisement, Shortcode & Widget for JNews). I have disabled it and Elementor left side starts working normally.

    This is really frustrating. Same thing is happening to me, but not only can I not edit any of my site, some widgets have actually disappeared on my pages, including my pricing chart, so right now when people come to my pricing page, there’s a big white blank spot under PRICING. And I can’t edit or change it.

    Same thing with other pages. Widgets missing. This is costing me money and getting support from Elementor is a 3 day adventure. Not happy at all with it.

    Hello All,

    I am new to this discussion, however I have been having some of the same issues. I started disabling all the plugins I had installed, and when I disabled JetPack, (Ver 7.3.1) the issue went completely away.

    Just thought I would pass this along, and see if it helps anyone else.


    Exactly Same Issue With Me , Woof Was Creating The Problem I Have Disabled It & Everything Is Fine Now ..

    Can you please help me to solve this problem?

    I have this issue with Multi-purpose New Magazine theme but elementor works with default theme.

    I also found the following error in console:

    editor.min.js?ver=2.5.16:2 Uncaught TypeError: Cannot set property ‘controls’ of undefined
    at Object.<anonymous> (editor.min.js?ver=2.5.16:2)
    at Function.each (load-scripts.php?c=1&load[]=underscore,jquery-core,jquery-migrate,backbone,shortcode,utils,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1.1:3)
    at Object.success (editor.min.js?ver=2.5.16:2)
    at i (load-scripts.php?c=1&load[]=underscore,jquery-core,jquery-migrate,backbone,shortcode,utils,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1.1:3)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=underscore,jquery-core,jquery-migrate,backbone,shortcode,utils,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1.1:3)
    at Object.e.<computed> [as resolve] (load-scripts.php?c=1&load[]=underscore,jquery-core,jquery-migrate,backbone,shortcode,utils,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1.1:3)
    at common.min.js?ver=2.5.16:2
    at Array.forEach (<anonymous>)
    at success (common.min.js?ver=2.5.16:2)
    at Object.i.success (common.min.js?ver=2.5.16:2)

    I did have same problem, when I deactivated Premium Addons for Elementor from Leap13 it works again. kinda wierd.

    IDK why they don’t acknowledge the problem….

    If you just add this if clause, it works then…
    “elementor/assets/js/editor.min.js” ->

    jQuery.each(t, function(t, n) {
        var i = e.config.widgets[t];
        i.controls = n.controls,
        i.tabs_controls = n.tabs_controls
    jQuery.each(t, function(t, n) {
        var i = e.config.widgets[t];
        if(i && n) { // this is new!
            i.controls = n.controls,
            i.tabs_controls = n.tabs_controls

    But with next update you will loose the fix again… hah!

    • This reply was modified 2 years, 3 months ago by Gaspa.
    • This reply was modified 2 years, 3 months ago by Gaspa.

    SOLVED – It’s because of a copypaste error, where it changes the ‘ symbol to a different one. Simply manually delete and retype the ‘ symbols and it’ll work – both Elementor and WOOF Product Filter.

    Screenshots here if above is unclear:

    Cheerio 🙂

    • This reply was modified 2 years, 1 month ago by michoscopic.
    • This reply was modified 2 years, 1 month ago by michoscopic.


    Hi! My Elementor Elements sidebar is not working. Kindly Help me



    Hey everyone, so I posted this in the elementor and elementor pro facebook groups but it seems people in this thread are still having problems.

    I cannot stress enough how much elementor hates EXTERNAL plug-ins, or literally anything that interacts with your web browser.

    I am in the process of building a massive website for a law firm, and while using these products one day the side bar stopped loading. I tested it at home, and on multiple browsers and scoured the internet doing just about EVERY single fix I could find, even on the hosting company side.

    One day it just started working. So I quick back tracked and retraced my steps. What I had found and tested was that since I do content creation, I use a paid tool called “Video Downloader Ultimate” which downloads to your desktop, and is NOT a browser plugin. BUT when turned on it interacts with the web browser and completely blocks my left side widget bar from loading.

    I went further and noticed that when I screen share with my team on something even as minimal as zoom it will even slow down the performance of elementor because it is still “INTERACTING” with the web browser.

    Im not a coding genius so I cant give an insanely technical answer to this, but what I suggest everyone do is turn off all of your browser plugins, and if it is still not working, check to see if you have any background programs running that interact with the internet and/or your web browser in any way and turn them off one at a time until you find the culprit.

    I have not seen this answer anywhere else online so I hope this helps everyone.

    We are also experiencing the left side (widgets) greyed out, not working, and the loading circle just keeps spinning.

    I would appreciate any assistance to help get our site back up to being able to be edited with elementor.

    Errors from the console window when the elementor editor page loads:

    JQMIGRATE: Migrate is installed, version 1.4.1 load-scripts.php:8:552
    window.controllers/Controllers is deprecated. Do not use it for UA detection. ace.js:1:18446
    TypeError: window.ui_init_object is undefined cherry-js-core.min.js:1:292
    TypeError: t.utilites is undefined ui-select.min.js:1:29
    TypeError: t.utilites is undefined ui-checkbox.min.js:1:29
    TypeError: e.utilites is undefined ui-radio.min.js:1:29
    TypeError: r.utilites is undefined ui-colorpicker.min.js:1:29
    TypeError: a.utilites is undefined ui-media.min.js:1:29
    TypeError: e.utilites is undefined ui-switcher.min.js:1:29
    TypeError: i.utilites is undefined ui-slider.min.js:1:29
    TypeError: t.utilites is undefined ui-repeater.min.js:1:29
    TypeError: t.utilites is undefined ui-iconpicker.min.js:1:31
    TypeError: CherryJsCore.utilites is undefined ui-dimensions.js:7:2
    TypeError: s.utilites is undefined cherry-interface-builder.min.js:1:29

    Plugins loaded with the site
    Note that all plugins except broken links, captcha, cache were included as part of the template we purchased. Cache is not active, installed only for an easy way to delete anything cached – and this was installed after the issue started.
    I tried to deactivate a few of the plugins below, but no change to elementors frozen state.

    Broken Link Checker - Version 1.11.9 | By ManageWP
    Cherry Data Importer - Version 1.1.2 | By TemplateMonster
    Cherry Plugin Wizard - Version 1.0.0 | By Cherry Team
    Cherry PopUps - Version 1.1.8 | By Jetimpex
    Cherry Projects - Version 1.2.15 | By Cherry Team
    Cherry Search - Version 1.1.5 | By Zemez
    Cherry Services List - Version 1.4.7 | By Zemez
    Cherry Sidebars - Version 1.1.3 | By Zemez
    Cherry Socialize - Version 1.1.4 | By Jetimpex
    Cherry Team Members - Version 1.4.6 | By Zemez
    Cherry Testimonials - Version 1.1.3 | By Zemez
    Cherry Trending Posts - Version 1.0.2 | By Zemez
    Contact Form 7 - Version 5.1.5 | By Takayuki Miyoshi
    Contact Form CFDB7 - Version | By Arshid
    Elementor - Version 2.7.5 | By
    JetElements For Elementor - Version 2.1.4 | By Zemez
    Jetimpex Dashboard - Version 1.1.0 | By Cherry Team
    JetMenu - Version 1.5.14 | By Zemez
    Really Simple CAPTCHA - Version 2.0.2 | By Takayuki Miyoshi
    TM Photo Gallery - Version 1.1.2 | By JetImpex
    TM Timeline - Version 1.1.1 | By Jetimpex
    WordPress Social Login - Version 2.3.3 | By Miled
    WP Super Cache - Version 1.7.0 | By Automattic

    thank you for any help!

    Dear All,
    in my elementor in the wp-admin is not showing the all widgets.
    for example they are missing the following:
    performance, appearence, plugins, settings and maybe a few more

    what can I do so I can see them in order to create backup and restore and install plugins etc


Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘elementor left side not working’ is closed to new replies.