Support » Plugin: Elementor Page Builder » Elementor lanugage

  • Resolved Carl Gross

    (@carlgross)


    Hello. This is a reply to a separate post in your support forums (this post). There, the original poster inquired about the language used in the Elementor editor. In it, a support agent said,

    >> In regards on how to get Elementor editor in English, I’m afraid that the language of Elementor editor depends on which language you have selected in the WordPress settings so far. https://imgur.com/a/cvlMV8h

    Well that’s exactly why I’m here. If I switch the WPML language in the admin bar to French, the Elementor editor changes to French, even though the language in Dashboard–>Users–>Your Profile is still English (screenshot). By your description, shouldn’t the Elementor editor remain in English in this case?

    Feel free to close the other ticket while we continue discussion here.

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Carl Gross

    (@carlgross)

    As you can see, when I try to edit a Chinese language page, the Elementor editor also changes to Chinese (screenshot). This makes it difficult to edit, as I cannot read Chinese.

    Plugin Support davidr90

    (@davidr90)

    Please make sure that you haven’t checked this WPML option in your profile settings (WordPress Dashboard > Users > Your profile account), this could change the Elementor language to the current language that you’re editing:
    https://imgur.com/a/tdmg7t0

    If you need further assistance with WPML, related questions should be asked on their side, they’d be in a better position to help you with this.

    Carl Gross

    (@carlgross)

    >> Please make sure that you haven’t checked this WPML option in your profile settings (WordPress Dashboard > Users > Your profile account), this could change the Elementor language to the current language that you’re editing:

    I had a look, and that box is not ticked (screenshot). I can also say that when I switch WPML languages via the admin bar, only the Elementor editor changes language. No other text in the WordPress back-end changes language.

    >> If you need further assistance with WPML, related questions should be asked on their side, they’d be in a better position to help you with this.

    I’m happy to open a ticket with WPML. But at this point, would you say we have isolated this to be a WPML issue, and not an Elementor issue? Or is there more troubleshooting we (or you) can do before we rule out Elementor as the cause?

    Thanks.

    Plugin Support davidr90

    (@davidr90)

    We have not received any global issues regarding Elementor and WPML, therefore it would be best to contact WPML support to see if there isn’t an issue with their compatibility with Elementor.

    You can also try deactivating all of your plugins except Elementor, to rule out any conflict with third-party plugins.

    >> You can also try deactivating all of your plugins except Elementor, to rule out any conflict with third-party plugins.

    I just tried deactivating all plugins except Elementor and WPML, and the issue was still present.

    >> We have not received any global issues regarding Elementor and WPML, therefore it would be best to contact WPML support to see if there isn’t an issue with their compatibility with Elementor.

    OK I can ask WPML. Should we keep this ticket open until I heard back from them? I can be sure to reply here.

    FYI I had a long discussion with WPML about this. The ticket is here, if you can see it. The short story is that they claim this was an Elementor issue, that was nearly universally resolved in a recent Elementor update. I say ‘nearly universally resolved’ because apparently *my site* has a very unique additional issue which is preventing that fix from working. The WPML agent gave an additional workaround fix for my site, which he claims would fix the issue. But I haven’t tried it, because that workaround is a bit time intensive.

    Just thought I’d update here in case anyone else is experiencing this issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.